Message boards : CMS Application : Ubuntu 20.04.1 and Hypervisor failed
Message board moderation

To post messages, you must log in.

AuthorMessage
Jim1348

Send message
Joined: 15 Nov 14
Posts: 517
Credit: 14,818,983
RAC: 19,667
Message 43780 - Posted: 4 Dec 2020, 16:06:11 UTC

After upgrading to Ubuntu 20.04.1 and VirtualBox 6.1.6., all my CMS fail with "Communication with VM Hypervisor failed".
There does not seem to be a way to go back to VBox 5.2.x, which would probably fix it.

I think this needs to be addressed at the LHC end.
ID: 43780 · Report as offensive     Reply Quote
computezrmle
Volunteer moderator
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 15 Jun 08
Posts: 1691
Credit: 103,136,603
RAC: 102,951
Message 43781 - Posted: 4 Dec 2020, 16:19:58 UTC - in response to Message 43780.  

From one of your logfiles:
VBoxManage: error: Failed to create the VirtualBox object!
VBoxManage: error: Code NS_ERROR_SOCKET_FAIL (0xC1F30200) - IPC daemon socket error (extended info not available)
VBoxManage: error: Most likely, the VirtualBox COM server is not running or failed to start.

Is VBox 6.1.6 the most recent version on Ubuntu?
Do VMs you created yourself before the upgrade also fail?
ID: 43781 · Report as offensive     Reply Quote
Jim1348

Send message
Joined: 15 Nov 14
Posts: 517
Credit: 14,818,983
RAC: 19,667
Message 43782 - Posted: 4 Dec 2020, 16:29:37 UTC - in response to Message 43781.  
Last modified: 4 Dec 2020, 16:34:26 UTC

Is VBox 6.1.6 the most recent version on Ubuntu?

It is the default one you get with Ubuntu 20.04.1 when you run "sudo apt install virtualbox".
You can get a later one (6.1.16) by using the instructions here, but that also fails:
https://www.virtualbox.org/wiki/Linux_Downloads

Do VMs you created yourself before the upgrade also fail?

I didn't upgrade to Ubuntu 20.04.1, but did a clean install.
My i7-9700 still on Ubuntu 18.04.5 works OK with VBox 5.2.42.
https://lhcathome.cern.ch/lhcathome/results.php?hostid=10671473
(And the Ryzen 3600 worked OK on CMS when it was still on Ubuntu 18.04.5 and it's default, which was VBox 5.2.42.)
ID: 43782 · Report as offensive     Reply Quote
computezrmle
Volunteer moderator
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 15 Jun 08
Posts: 1691
Credit: 103,136,603
RAC: 102,951
Message 43783 - Posted: 4 Dec 2020, 16:39:55 UTC - in response to Message 43782.  

... did a clean install.

I would try to run a self created VM using the boinc user account to see if VirtualBox works fine with Ubuntu 20.04.1.
ID: 43783 · Report as offensive     Reply Quote
Jim1348

Send message
Joined: 15 Nov 14
Posts: 517
Credit: 14,818,983
RAC: 19,667
Message 43784 - Posted: 4 Dec 2020, 18:05:24 UTC - in response to Message 43783.  
Last modified: 4 Dec 2020, 18:19:43 UTC

I would try to run a self created VM using the boinc user account to see if VirtualBox works fine with Ubuntu 20.04.1.

Be my guest. I have never self-created a VM (at least not successfully).
There are probably people here who do it routinely though.

Maybe I did not make it clear that I don't need it now. The i7-9700 is all I need.
It is more in the nature of reporting to LHC that they may see problems.
ID: 43784 · Report as offensive     Reply Quote
computezrmle
Volunteer moderator
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 15 Jun 08
Posts: 1691
Credit: 103,136,603
RAC: 102,951
Message 43792 - Posted: 5 Dec 2020, 9:10:47 UTC

ID: 43792 · Report as offensive     Reply Quote
Jim1348

Send message
Joined: 15 Nov 14
Posts: 517
Credit: 14,818,983
RAC: 19,667
Message 43946 - Posted: 19 Dec 2020, 3:04:58 UTC - in response to Message 43792.  

Not sure if this will solve the problem:
https://forums.virtualbox.org/viewtopic.php?f=8&t=83234
https://www.virtualbox.org/ticket/2335

It is probably related to the obscure BOINC problem concerning temporary files being discussed on GPUGrid.
http://www.gpugrid.net/forum_thread.php?id=5204&nowrap=true#55993

So I upgraded from BOINC 7.16.11 to 7.16.14 but that did not fix it.
I will do something else on the Ubuntu 20.04.1 machines until there is a fix.

Thanks for the input.
ID: 43946 · Report as offensive     Reply Quote
Jim1348

Send message
Joined: 15 Nov 14
Posts: 517
Credit: 14,818,983
RAC: 19,667
Message 43962 - Posted: 20 Dec 2020, 20:45:35 UTC - in response to Message 43782.  

My i7-9700 still on Ubuntu 18.04.5 works OK with VBox 5.2.42.
https://lhcathome.cern.ch/lhcathome/results.php?hostid=10671473

No longer. After upgrading this machine to Linux kernel 5.4.0-58 (from 5.4.0-52) I started getting failures, so I had to abort them.
Also, BOINC updated from 7.16.11 to 7.16.14 at that time, which may be relevant.
But the VirtualBox version stayed the same at 5.2.42.

There is something strange about that upgrade. It is causing problems for me on QuChemPedIA also on two machines, a Ryzen 3900X and the i7-9700.
(Both are on Ubuntu 18.04.5). And QuChemPedIA is not a virtualbox project, at least for Linux, though it is used for Windows machines.
ID: 43962 · Report as offensive     Reply Quote
Greger

Send message
Joined: 9 Jan 15
Posts: 146
Credit: 431,534,851
RAC: 52,959
Message 43963 - Posted: 21 Dec 2020, 0:34:43 UTC - in response to Message 43962.  
Last modified: 21 Dec 2020, 0:54:26 UTC

You mention Ubuntu 20.04.1 before in last post. If still have it could you try ubuntu apt package with boinc-client boinc-manager with virtualbox 6.1.16
Could you try
sudo apt-get boinc-client boinc-manager
and get directly from apt package.
Have been stable to LHC and Cosmology for me with these.

on 18.04 i don't know which release would be best but 6.1 is possible. You might use PPA from costamagnagianfranco or https://launchpad.net/ubuntu/+source/boinc
There could issue use them with virtualbox?
Updating kernel could be an issue you try adding dkms to virtualbox.
sudo apt-get install virtualbox-dkms 


Then use virtualbox package from https://www.virtualbox.org/wiki/Linux_Downloads
ID: 43963 · Report as offensive     Reply Quote
Jim1348

Send message
Joined: 15 Nov 14
Posts: 517
Credit: 14,818,983
RAC: 19,667
Message 43964 - Posted: 21 Dec 2020, 2:38:35 UTC - in response to Message 43963.  

on 18.04 i don't know which release would be best but 6.1 is possible. You might use PPA from costamagnagianfranco or https://launchpad.net/ubuntu/+source/boinc
There could issue use them with virtualbox?
Updating kernel could be an issue you try adding dkms to virtualbox.
sudo apt-get install virtualbox-dkms 


Then use virtualbox package from https://www.virtualbox.org/wiki/Linux_Downloads

I can answer that part first. I didn't have a problem with VirtualBox 5.2.42. It was only when I upgraded the Linux kernel to 5.4.0-58 (from 5.4.0-52) that I started getting failures.
And I did get my BOINC from PPA costamagnagianfranco, which is why it updated from 7.16.11 to 7.16.14.
I think upgrading to VirtualBox 6.1.x is heading in the wrong direction from what I have seen.

But I will try you suggestions for the Ubuntu 20.04.1 installation shortly.
ID: 43964 · Report as offensive     Reply Quote
Jim1348

Send message
Joined: 15 Nov 14
Posts: 517
Credit: 14,818,983
RAC: 19,667
Message 43965 - Posted: 21 Dec 2020, 3:06:48 UTC - in response to Message 43963.  
Last modified: 21 Dec 2020, 3:21:40 UTC

You mention Ubuntu 20.04.1 before in last post. If still have it could you try ubuntu apt package with boinc-client boinc-manager with virtualbox 6.1.16
Could you try
sudo apt-get boinc-client boinc-manager
and get directly from apt package.
Have been stable to LHC and Cosmology for me with these.

OK, I get:
$ sudo apt-get boinc-client boinc-manager
E: Invalid operation boinc-client

Let me know what else I should try, but I installed BOINC from PPA costamagnagianfranco on that machine too (the Ryzen 3600), and it works fine otherwise.

PS - I have had problems on Cosmology also with VirtualBox 6.1.6, but I tried it again on that machine, and got the same thing:
2.05 camb_boinc2docker (vbox64_mt) 4C Waiting to run,Suspended: Communication with VM Hypervisor failed.
ID: 43965 · Report as offensive     Reply Quote
Greger

Send message
Joined: 9 Jan 15
Posts: 146
Credit: 431,534,851
RAC: 52,959
Message 43966 - Posted: 21 Dec 2020, 3:52:20 UTC
Last modified: 21 Dec 2020, 3:59:53 UTC

Sorry need to add install into it.
sudo apt-get install boinc-client boinc-manager


The thing is that i would like to see if have any affect on how costa package handle virtualbox and 6.1.16 have been solid on ubuntu 20.01. Only experience it not always been detect after reboot in boinc-client.

On start make sure it detect and use correct version if not it would need a restart boinc service.
sudo service boinc-client restart
same as for 18.04.
ID: 43966 · Report as offensive     Reply Quote
Jim1348

Send message
Joined: 15 Nov 14
Posts: 517
Credit: 14,818,983
RAC: 19,667
Message 43975 - Posted: 21 Dec 2020, 14:15:53 UTC - in response to Message 43966.  

OK, I get:
$ sudo apt-get install boinc-client boinc-manager
[sudo] password for jim:
Reading package lists... Done
Building dependency tree
Reading state information... Done
boinc-client is already the newest version (7.16.15+dfsg.is.7.16.14+dfsg+202012051753~ubuntu20.04.1).
boinc-client set to manually installed.
boinc-manager is already the newest version (7.16.15+dfsg.is.7.16.14+dfsg+202012051753~ubuntu20.04.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Does that answer the question?
ID: 43975 · Report as offensive     Reply Quote
Greger

Send message
Joined: 9 Jan 15
Posts: 146
Credit: 431,534,851
RAC: 52,959
Message 43976 - Posted: 21 Dec 2020, 17:48:53 UTC - in response to Message 43975.  

Old boinc need to be removed inactive PPA repo for Costaboinca. Go to software and update and uncheck line for that PPA then:

sudo apt-get remove boinc-client boinc-manager

And try again with same but install to get package from apt repo.
ID: 43976 · Report as offensive     Reply Quote
Jim1348

Send message
Joined: 15 Nov 14
Posts: 517
Credit: 14,818,983
RAC: 19,667
Message 43977 - Posted: 21 Dec 2020, 20:11:56 UTC - in response to Message 43976.  
Last modified: 21 Dec 2020, 20:22:28 UTC

And try again with same but install to get package from apt repo.

It worked perfectly, and I am now running 12 CMS on BOINC 7.16.6 (and VirtualBox 6.1.6).
https://lhcathome.cern.ch/lhcathome/results.php?hostid=10666095
EDIT: Two errored out after 22 minutes, but that is a different problem.
The others have gone past the time of early failures.

This will solve more than one strange problem I have been having.
It appears that there is something seriously wrong with 7.16.14, at least on PPA costamagnagianfranco.
So I will stick to the apt repo, which is simpler anyway.

Thanks loads.
I will notify whatever other projects that have been having problems, but if you would take care of the PPA (or BOINC), you could do that better than I.
ID: 43977 · Report as offensive     Reply Quote
Greger

Send message
Joined: 9 Jan 15
Posts: 146
Credit: 431,534,851
RAC: 52,959
Message 43978 - Posted: 21 Dec 2020, 20:38:26 UTC - in response to Message 43977.  

Good thanks for trying it.
ID: 43978 · Report as offensive     Reply Quote

Message boards : CMS Application : Ubuntu 20.04.1 and Hypervisor failed


©2021 CERN