Message boards : Number crunching : Keep getting no tasks available errors
Message board moderation

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
greg_be

Send message
Joined: 28 Dec 08
Posts: 242
Credit: 1,589,914
RAC: 2,073
Message 42286 - Posted: 25 Apr 2020, 22:35:05 UTC
Last modified: 25 Apr 2020, 22:36:48 UTC

4/25/2020 1:12:20 PM | LHC@home | No tasks are available for CMS Simulation
4/25/2020 1:12:20 PM | LHC@home | No tasks are available for Theory Simulation
4/25/2020 1:12:20 PM | LHC@home | No tasks are available for ATLAS Simulation

I am still getting Theory tasks, but I lost ATLAS awhile back.
What changes to the configuration of my account do i need to make or to BOINC?

I used to run just ATLAS, but a week or two ago I lost the Ability to run them, that or COVID messed up that teams ability to generate work. I am not sure which.

Also BOINC keeps hitting the server for more work and I keep getting "project requested a delay of....seconds"
ID: 42286 · Report as offensive     Reply Quote
Gunde

Send message
Joined: 9 Jan 15
Posts: 122
Credit: 396,417,646
RAC: 343,931
Message 42294 - Posted: 26 Apr 2020, 20:34:45 UTC
Last modified: 26 Apr 2020, 20:41:48 UTC

Could try uncheck theory and suspend other project to fetch more work. Check if got enough disk space then wait.
It could be dry at time it updated to project.

If it there is no work it probably no work at that time.

EDIT:

Checked one of my host and it uploaded 2 task and downloaded 3 new

Sun 26 Apr 2020 10:37:31 PM CEST | LHC@home | update requested by user
Sun 26 Apr 2020 10:37:37 PM CEST | LHC@home | Sending scheduler request: Requested by user.
Sun 26 Apr 2020 10:37:37 PM CEST | LHC@home | Reporting 2 completed tasks
Sun 26 Apr 2020 10:37:37 PM CEST | LHC@home | Requesting new tasks for CPU
Sun 26 Apr 2020 10:37:38 PM CEST | LHC@home | Scheduler request completed: got 3 new tasks
Sun 26 Apr 2020 10:37:40 PM CEST | LHC@home | Started download of 3nYLDm4izmwn9Rq4apoT9bVoABFKDmABFKDmas0SDmABFKDmv55Fnn_EVNT.19652227._001072.pool.root.1
Sun 26 Apr 2020 10:37:40 PM CEST | LHC@home | Started download of 3nYLDm4izmwn9Rq4apoT9bVoABFKDmABFKDmas0SDmABFKDmv55Fnn_input.tar.gz
Sun 26 Apr 2020 10:37:42 PM CEST | LHC@home | Finished download of 3nYLDm4izmwn9Rq4apoT9bVoABFKDmABFKDmas0SDmABFKDmv55Fnn_input.tar.gz
Sun 26 Apr 2020 10:37:42 PM CEST | LHC@home | Started download of rte_3nYLDm4izmwn9Rq4apoT9bVoABFKDmABFKDmas0SDmABFKDmv55Fnn.tar.gz
Sun 26 Apr 2020 10:37:43 PM CEST | LHC@home | Finished download of rte_3nYLDm4izmwn9Rq4apoT9bVoABFKDmABFKDmas0SDmABFKDmv55Fnn.tar.gz
Sun 26 Apr 2020 10:37:43 PM CEST | LHC@home | Started download of boinc_job_script.2wlQLm
Sun 26 Apr 2020 10:37:45 PM CEST | LHC@home | Finished download of boinc_job_script.2wlQLm
Sun 26 Apr 2020 10:37:45 PM CEST | LHC@home | Started download of E8sKDmNizmwn9Rq4apoT9bVoABFKDmABFKDm5R0SDmABFKDm33Aqlm_EVNT.19652227._001071.pool.root.1


So for now it should be task available.
ID: 42294 · Report as offensive     Reply Quote
greg_be

Send message
Joined: 28 Dec 08
Posts: 242
Credit: 1,589,914
RAC: 2,073
Message 42307 - Posted: 27 Apr 2020, 19:39:18 UTC - in response to Message 42294.  
Last modified: 27 Apr 2020, 20:08:30 UTC

Could try uncheck theory and suspend other project to fetch more work. Check if got enough disk space then wait.
It could be dry at time it updated to project.

If it there is no work it probably no work at that time.

EDIT:

Checked one of my host and it uploaded 2 task and downloaded 3 new

Sun 26 Apr 2020 10:37:31 PM CEST | LHC@home | update requested by user
Sun 26 Apr 2020 10:37:37 PM CEST | LHC@home | Sending scheduler request: Requested by user.
Sun 26 Apr 2020 10:37:37 PM CEST | LHC@home | Reporting 2 completed tasks
Sun 26 Apr 2020 10:37:37 PM CEST | LHC@home | Requesting new tasks for CPU
Sun 26 Apr 2020 10:37:38 PM CEST | LHC@home | Scheduler request completed: got 3 new tasks
Sun 26 Apr 2020 10:37:40 PM CEST | LHC@home | Started download of 3nYLDm4izmwn9Rq4apoT9bVoABFKDmABFKDmas0SDmABFKDmv55Fnn_EVNT.19652227._001072.pool.root.1
Sun 26 Apr 2020 10:37:40 PM CEST | LHC@home | Started download of 3nYLDm4izmwn9Rq4apoT9bVoABFKDmABFKDmas0SDmABFKDmv55Fnn_input.tar.gz
Sun 26 Apr 2020 10:37:42 PM CEST | LHC@home | Finished download of 3nYLDm4izmwn9Rq4apoT9bVoABFKDmABFKDmas0SDmABFKDmv55Fnn_input.tar.gz
Sun 26 Apr 2020 10:37:42 PM CEST | LHC@home | Started download of rte_3nYLDm4izmwn9Rq4apoT9bVoABFKDmABFKDmas0SDmABFKDmv55Fnn.tar.gz
Sun 26 Apr 2020 10:37:43 PM CEST | LHC@home | Finished download of rte_3nYLDm4izmwn9Rq4apoT9bVoABFKDmABFKDmas0SDmABFKDmv55Fnn.tar.gz
Sun 26 Apr 2020 10:37:43 PM CEST | LHC@home | Started download of boinc_job_script.2wlQLm
Sun 26 Apr 2020 10:37:45 PM CEST | LHC@home | Finished download of boinc_job_script.2wlQLm
Sun 26 Apr 2020 10:37:45 PM CEST | LHC@home | Started download of E8sKDmNizmwn9Rq4apoT9bVoABFKDmABFKDm5R0SDmABFKDm33Aqlm_EVNT.19652227._001071.pool.root.1


So for now it should be task available.


Here is the problem: 4/27/2020 9:48:26 PM | LHC@home | Your app_config.xml file refers to an unknown application 'ATLAS'. Known applications: 'Theory'


How can ATLAS be unknown?!?
.I have had this line in my app_config forever and it always worked.
<name>ATLAS</name>

This is my total app_config that I have for keeping ATLAS under control on my system (long story).


<app_config>
<project_max_concurrent>2</project_max_concurrent>
<app>
<name>ATLAS</name>
<max_concurrent>1</max_concurrent>
</app>
<app_version>
<app_name>ATLAS</app_name>
<plan_class>vbox64_mt_mcore_atlas</plan_class>
<avg_ncpus>4.000000</avg_ncpus>
<cmdline>--memory_size_mb 6600</cmdline>
</app_version>
</app_config>

BOINC is current, VBOX is now at 6.1.6 with extension pack.
So what the heck is happening in app_config?

BTW: 4/27/2020 10:04:08 PM | LHC@home | No tasks are available for CMS Simulation
4/27/2020 10:04:08 PM | LHC@home | No tasks are available for Theory Simulation
4/27/2020 10:04:08 PM | LHC@home | No tasks are available for ATLAS Simulation

But yet there are tasks for Theory and for ATLAS
ID: 42307 · Report as offensive     Reply Quote
Gunde

Send message
Joined: 9 Jan 15
Posts: 122
Credit: 396,417,646
RAC: 343,931
Message 42310 - Posted: 27 Apr 2020, 21:23:54 UTC - in response to Message 42307.  
Last modified: 27 Apr 2020, 21:27:28 UTC

4/27/2020 9:48:26 PM | LHC@home | Your app_config.xml file refers to an unknown application 'ATLAS'. Known applications: 'Theory'


That is default message and would only mean that could not any work on client for that application at time but for Theory. This post would change as soon as it detect any task for ATLAS.
It great follow these post to find correct application names but this just to ignore when client get out of work.
Config is probably fine if not is would post other things then that. So in short that "issue post" is in reality to write over possible negative real issue post, so what i really say "it works" but it can't define that as no work is found to client.
Just a way to learn how to troubleshoot in this BOINC environment.

You would need to verify with someone that use application ATlAS (vbox64_mt_mcore_atlas) if they got same response from server that would indicate that server out of work. I use native so i can't compare mine to yours to troubleshoot.

Work would go under same category of app ATLAS but work from scheduler would handle request and files differently so project setting would probably be different.
ID: 42310 · Report as offensive     Reply Quote
computezrmle
Volunteer moderator
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 15 Jun 08
Posts: 1553
Credit: 89,007,149
RAC: 94,985
Message 42317 - Posted: 28 Apr 2020, 4:59:54 UTC

greg_be wrote:
4/27/2020 9:48:26 PM | LHC@home | Your app_config.xml file refers to an unknown application 'ATLAS'. Known applications: 'Theory'

The reason why you get this message is that you did a project reset.
After a project reset your local BOINC client doesn't know anything about ATLAS (or any other subproject).
After your BOINC client got it's 1st ATLAS task you'll have to reload the config files again.
Otherwise ATLAS will run with default setting sent by the server.

The latter might be the reason why you don't get ATLAS tasks.
In your app_config.xml ATLAS is set to 4 cores. Hence your web preferences should also be set to 4 cores.
ID: 42317 · Report as offensive     Reply Quote
greg_be

Send message
Joined: 28 Dec 08
Posts: 242
Credit: 1,589,914
RAC: 2,073
Message 42320 - Posted: 28 Apr 2020, 6:45:44 UTC - in response to Message 42317.  
Last modified: 28 Apr 2020, 6:48:34 UTC

greg_be wrote:
4/27/2020 9:48:26 PM | LHC@home | Your app_config.xml file refers to an unknown application 'ATLAS'. Known applications: 'Theory'

The reason why you get this message is that you did a project reset.
After a project reset your local BOINC client doesn't know anything about ATLAS (or any other subproject).
After your BOINC client got it's 1st ATLAS task you'll have to reload the config files again.
Otherwise ATLAS will run with default setting sent by the server.

The latter might be the reason why you don't get ATLAS tasks.
In your app_config.xml ATLAS is set to 4 cores. Hence your web preferences should also be set to 4 cores.



Ok I did a project reset awhile back, but even then it said no work for ATLAS
I left it open for ATLAS only for awhile and got nothing.
Web settings are for 4 cores as is the app_config core setting.
Last night EU time there were 2240 tasks on ATLAS waiting to go out.
I could not get any of them.

To keep busy I left CMS and Theory open overnight, from the time of this post those have been unchecked and ATLAS is the only project checked.
There are currently 2096 tasks sitting in ATLAS.

I have to go work, so in 12hrs I will look through the event log and see what has happened.
ID: 42320 · Report as offensive     Reply Quote
greg_be

Send message
Joined: 28 Dec 08
Posts: 242
Credit: 1,589,914
RAC: 2,073
Message 42331 - Posted: 28 Apr 2020, 20:00:38 UTC - in response to Message 42320.  
Last modified: 28 Apr 2020, 20:04:24 UTC

greg_be wrote:
4/27/2020 9:48:26 PM | LHC@home | Your app_config.xml file refers to an unknown application 'ATLAS'. Known applications: 'Theory'

The reason why you get this message is that you did a project reset.
After a project reset your local BOINC client doesn't know anything about ATLAS (or any other subproject).
After your BOINC client got it's 1st ATLAS task you'll have to reload the config files again.
Otherwise ATLAS will run with default setting sent by the server.

The latter might be the reason why you don't get ATLAS tasks.
In your app_config.xml ATLAS is set to 4 cores. Hence your web preferences should also be set to 4 cores.



Ok I did a project reset awhile back, but even then it said no work for ATLAS
I left it open for ATLAS only for awhile and got nothing.
Web settings are for 4 cores as is the app_config core setting.
Last night EU time there were 2240 tasks on ATLAS waiting to go out.
I could not get any of them.

To keep busy I left CMS and Theory open overnight, from the time of this post those have been unchecked and ATLAS is the only project checked.
There are currently 2096 tasks sitting in ATLAS.

I have to go work, so in 12hrs I will look through the event log and see what has happened.


So got an ATLAS task finally, but the event log does not say it ever downloaded.
This was the same for the Theory tasks. Says no tasks available, but yet they are magically running on my system.
Something is buggy in the communications between my system and the server!
ID: 42331 · Report as offensive     Reply Quote
greg_be

Send message
Joined: 28 Dec 08
Posts: 242
Credit: 1,589,914
RAC: 2,073
Message 42332 - Posted: 28 Apr 2020, 22:29:59 UTC

This is weird. BOINC says NO tasks of any kind have been sent since the 27th.
Yet according to my account page I have processed 4 out 5 ATLAS tasks since 12:40 something pm on the 28th.
Boinc's last com for ATLAS was 5:29pm on the 28th and no tasks.
BUT...according to my account page the last task was sent out at 5:48pm on the 28th.
Last completed task was on the 28th an reported at 9:05pm, but BOINC has no record of this.
But I notice none of the other projects are reporting anything routine either.
Just back off times and if there is an error, otherwise nothing, other than LHC saying there is no work, but loading work anyway.
ID: 42332 · Report as offensive     Reply Quote
computezrmle
Volunteer moderator
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 15 Jun 08
Posts: 1553
Credit: 89,007,149
RAC: 94,985
Message 42341 - Posted: 30 Apr 2020, 11:52:56 UTC - in response to Message 42332.  

Last time I saw things like that the reason was a misconfigured BOINC installation where 2 clients were fighting against each other.
You may check if you accidentally run 2 client instances, maybe 1st one as service and 2nd one started manually.

They may not even run concurrently but could be configured to use:
- the same working directory
- the same RPC port
- the same hostid

The latter could be tricky to solve as the project server creates the hostid and tends to keep it as long as major specs don't change.

2 concurrently running instances would also explain the RAM issues you mentioned a couple of weeks ago.
ID: 42341 · Report as offensive     Reply Quote
greg_be

Send message
Joined: 28 Dec 08
Posts: 242
Credit: 1,589,914
RAC: 2,073
Message 42344 - Posted: 30 Apr 2020, 23:23:09 UTC - in response to Message 42341.  

Ok..well in the morning (since it is labor day in Belgium and I don't have to work) I will stop all my projects and uninstall BOINC with Revo Uninstaller (which will wipe all the registry values and all traces of the program) and reinstall it and see if that changes things.

Fingers crossed!
ID: 42344 · Report as offensive     Reply Quote
Gunde

Send message
Joined: 9 Jan 15
Posts: 122
Credit: 396,417,646
RAC: 343,931
Message 42345 - Posted: 1 May 2020, 0:28:46 UTC - in response to Message 42344.  

Does Revo Uninstaller delete every datadirectory created to it? Possible issue looks to be that service or daemon is added if so the registry may not solve it if boinc.

Revo and external uninstaller tools could be good to wipe registry but may not purge external added data folders.
The uninstaller would ask to delete data folder.
ID: 42345 · Report as offensive     Reply Quote
Profile MAGIC Quantum Mechanic
Avatar

Send message
Joined: 24 Oct 04
Posts: 969
Credit: 41,013,040
RAC: 6,508
Message 42346 - Posted: 1 May 2020, 1:29:54 UTC

I just decided to try this here just to see if this works or not (I usually just do testing)

Here is the settings for my Preferences here.


Seconds later I got ATLAS .vdi d/ling and tasks to run



So apparently that is the way to set the Preferences to get the ATLAS tasks here (at least with the OS and Boinc settings I also use 100% CPU and 98% Ram)
ID: 42346 · Report as offensive     Reply Quote
greg_be

Send message
Joined: 28 Dec 08
Posts: 242
Credit: 1,589,914
RAC: 2,073
Message 42350 - Posted: 1 May 2020, 11:24:21 UTC - in response to Message 42345.  

Does Revo Uninstaller delete every datadirectory created to it? Possible issue looks to be that service or daemon is added if so the registry may not solve it if boinc.

Revo and external uninstaller tools could be good to wipe registry but may not purge external added data folders.
The uninstaller would ask to delete data folder.


Indeed it does ask to delete all external files (data folders, etc)
Since I did not do that step and after reinstalling BOINC and still getting the errror message no new tasks available, there must be something corrupt in the LHC folder.

So, I am setting all projects to 'no new tasks' and then wiping (via Revo) all folders. Total purge of BOINC.
Then reinstall and reconnect and see what that does.
Pretty drastic step, but only thing I can think of.
ID: 42350 · Report as offensive     Reply Quote
greg_be

Send message
Joined: 28 Dec 08
Posts: 242
Credit: 1,589,914
RAC: 2,073
Message 42351 - Posted: 1 May 2020, 11:25:02 UTC - in response to Message 42346.  

I just decided to try this here just to see if this works or not (I usually just do testing)

Here is the settings for my Preferences here.


Seconds later I got ATLAS .vdi d/ling and tasks to run



So apparently that is the way to set the Preferences to get the ATLAS tasks here (at least with the OS and Boinc settings I also use 100% CPU and 98% Ram)



Been there, done that, that is not the issue.
It's deeper than preferences.
ID: 42351 · Report as offensive     Reply Quote
greg_be

Send message
Joined: 28 Dec 08
Posts: 242
Credit: 1,589,914
RAC: 2,073
Message 42352 - Posted: 1 May 2020, 11:25:46 UTC - in response to Message 42341.  

Last time I saw things like that the reason was a misconfigured BOINC installation where 2 clients were fighting against each other.
You may check if you accidentally run 2 client instances, maybe 1st one as service and 2nd one started manually.

They may not even run concurrently but could be configured to use:
- the same working directory
- the same RPC port
- the same hostid

The latter could be tricky to solve as the project server creates the hostid and tends to keep it as long as major specs don't change.

2 concurrently running instances would also explain the RAM issues you mentioned a couple of weeks ago.


Wiped out BOINC and reinstalled, but left data directories intact, did not solve the problem.
Still same error message.
ID: 42352 · Report as offensive     Reply Quote
maeax

Send message
Joined: 2 May 07
Posts: 1028
Credit: 35,791,094
RAC: 25,763
Message 42353 - Posted: 1 May 2020, 11:59:55 UTC - in response to Message 42352.  

When you detach the LHC-Projekt and making a new attach?
ID: 42353 · Report as offensive     Reply Quote
greg_be

Send message
Joined: 28 Dec 08
Posts: 242
Credit: 1,589,914
RAC: 2,073
Message 42361 - Posted: 1 May 2020, 17:10:29 UTC - in response to Message 42353.  

When you detach the LHC-Projekt and making a new attach?


Can you be more clear in what you are saying?
Attach?
ID: 42361 · Report as offensive     Reply Quote
maeax

Send message
Joined: 2 May 07
Posts: 1028
Credit: 35,791,094
RAC: 25,763
Message 42362 - Posted: 1 May 2020, 19:04:22 UTC - in response to Message 42361.  

Disconnect the Project and than a new connect.
BTW for me get also the message in the moment: no tasks are available for Theory/CMS on one Computer.
ID: 42362 · Report as offensive     Reply Quote
greg_be

Send message
Joined: 28 Dec 08
Posts: 242
Credit: 1,589,914
RAC: 2,073
Message 42363 - Posted: 1 May 2020, 19:08:55 UTC - in response to Message 42362.  

Disconnect the Project and than a new connect.
BTW for me get also the message in the moment: no tasks are available for Theory/CMS on one Computer.


That is one of the first things I did when I noticed that ATLAS tasks had dried up.
First I am going to run out all the tasks from all the projects I have, then I will unistall and wipe out the data directories. Then I will do a system cleaning of the registry and all that stuff. If I get this same error again then I will try a reset.

Weird thing is I got about 5 ATLAS tasks while BOINC and the project insisted there was no work. But after those 5, I have gotten nothing.
ID: 42363 · Report as offensive     Reply Quote
greg_be

Send message
Joined: 28 Dec 08
Posts: 242
Credit: 1,589,914
RAC: 2,073
Message 42372 - Posted: 3 May 2020, 12:09:27 UTC

For some reason BOINC 7.16 does not run on my system properly.
I'll skip the details, but in short after clearing everything and reinstalling 7.14 things are back to normal.
I had to put back app_config.xml because my system will not run 2 ATLAS tasks at one time.
That's always been a thing. If I can run 2 then one or both crashes or stalls.
Seems that the obvious thing was the best thing to do in the first place.
ID: 42372 · Report as offensive     Reply Quote
1 · 2 · Next

Message boards : Number crunching : Keep getting no tasks available errors


©2020 CERN