Message boards : ATLAS application : Using 8 CPUs even if not showing 8 used?
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Joseph Stateson

Send message
Joined: 10 Aug 08
Posts: 15
Credit: 741,892
RAC: 7
Message 41807 - Posted: 3 Mar 2020, 0:23:27 UTC

Have 12c/24t dual xeon running
Pair of Atlas (8 + 8)
One theory (1)
Pair of Einstein (2)
Five WCG (5)
The above add up to 24 threads but BOINC shows only one of the Atlas having 8 CPUs.
Bug in BOINC?
Atlas really running on 1 CPU?
Four images attached. Three of them are snapshots of the Boinc Manager to show that it agrees with the Boinctasks image.
https://stateson.net/images/lhc_results2.png
https://stateson.net/images/lhc_results1.png
https://stateson.net/images/lhc_results3.png


My understanding of the LINUX mpstat command is that the "nice" column shows %utilization. I cannot tell if all CPUs are at %100, maybe yes, may no? Note that if you count up "running" tasks there are NOT 24 unless you assume the first atlas really has 8. In any event BOINC thinks it has allocated all the CPUs because there are some WCG ready to run but no CPUs for them.

root@jysdualxeon:/home/jstateson# mpstat -P ALL
Linux 5.3.0-40-generic (jysdualxeon)    03/02/2020      _x86_64_        (24 CPU)

06:08:32 PM  CPU    %usr   %nice    %sys %iowait    %irq   %soft  %steal  %guest  %gnice   %idle
06:08:32 PM  all    0.25   69.93    0.61    0.44    0.00    0.30    0.00    0.00    0.00   28.46
06:08:32 PM    0    0.43   45.43    0.94    0.76    0.00    4.39    0.00    0.00    0.00   48.05
06:08:32 PM    1    0.32   67.71    0.68    0.32    0.00    1.00    0.00    0.00    0.00   29.96
06:08:32 PM    2    0.31   70.00    0.65    0.47    0.00    0.49    0.00    0.00    0.00   28.07
06:08:32 PM    3    0.25   74.97    0.62    0.39    0.00    0.29    0.00    0.00    0.00   23.49
06:08:32 PM    4    0.26   77.36    0.56    0.38    0.00    0.20    0.00    0.00    0.00   21.23
06:08:32 PM    5    0.33   76.79    0.66    0.46    0.00    0.34    0.00    0.00    0.00   21.43
06:08:32 PM    6    0.13   81.06    0.50    0.35    0.00    0.08    0.00    0.00    0.00   17.87
06:08:32 PM    7    0.13   81.54    0.52    0.39    0.00    0.05    0.00    0.00    0.00   17.36
06:08:32 PM    8    0.14   81.23    0.50    0.23    0.00    0.05    0.00    0.00    0.00   17.86
06:08:32 PM    9    0.14   82.12    0.50    0.24    0.00    0.03    0.00    0.00    0.00   16.96
06:08:32 PM   10    0.12   82.72    0.49    0.25    0.00    0.03    0.00    0.00    0.00   16.38
06:08:32 PM   11    0.12   82.30    0.47    0.31    0.00    0.02    0.00    0.00    0.00   16.76
06:08:32 PM   12    0.32   72.93    0.64    0.44    0.00    0.04    0.00    0.00    0.00   25.62
06:08:32 PM   13    0.33   63.40    0.65    0.49    0.00    0.02    0.00    0.00    0.00   35.11
06:08:32 PM   14    0.35   61.90    0.66    0.41    0.00    0.01    0.00    0.00    0.00   36.67
06:08:32 PM   15    0.35   57.75    0.74    0.58    0.00    0.01    0.00    0.00    0.00   40.57
06:08:32 PM   16    0.38   55.00    0.74    0.71    0.00    0.01    0.00    0.00    0.00   43.16
06:08:32 PM   17    0.38   53.64    0.80    0.67    0.00    0.00    0.00    0.00    0.00   44.50
06:08:32 PM   18    0.23   69.44    0.60    0.39    0.00    0.00    0.00    0.00    0.00   29.34
06:08:32 PM   19    0.17   69.91    0.54    0.40    0.00    0.00    0.00    0.00    0.00   28.97
06:08:32 PM   20    0.19   69.23    0.53    0.71    0.00    0.00    0.00    0.00    0.00   29.34
06:08:32 PM   21    0.24   65.25    0.58    0.47    0.00    0.03    0.00    0.00    0.00   33.44
06:08:32 PM   22    0.20   67.21    0.58    0.32    0.00    0.00    0.00    0.00    0.00   31.69
06:08:32 PM   23    0.18   70.29    0.58    0.41    0.00    0.00    0.00    0.00    0.00   28.54

ID: 41807 · Report as offensive     Reply Quote
computezrmle
Volunteer moderator
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 15 Jun 08
Posts: 1439
Credit: 74,171,394
RAC: 109,370
Message 41808 - Posted: 3 Mar 2020, 7:31:03 UTC - in response to Message 41807.  

The ATLAS task reported with "8C" is using 8 cores. The other ATLAS task is using 1 core.
This behavior appears when you change the web preferences or the settings in an app_config.xml.
Tasks that are already downloaded keep the settings from before the change.
Fresh tasks get the settings from after the change.

Did you recently change the preferences?
ID: 41808 · Report as offensive     Reply Quote
computezrmle
Volunteer moderator
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 15 Jun 08
Posts: 1439
Credit: 74,171,394
RAC: 109,370
Message 41809 - Posted: 3 Mar 2020, 7:53:41 UTC

Just checked one of your logs and noticed that your local CVMFS client is misconfigured:
[2020-03-02 16:28:16] Probing /cvmfs/atlas.cern.ch... OK
[2020-03-02 16:28:17] Probing /cvmfs/atlas-condb.cern.ch... OK
[2020-03-02 16:28:23] Probing /cvmfs/lhcb.cern.ch... OK
[2020-03-02 16:28:26] Probing /cvmfs/alice.cern.ch... OK
[2020-03-02 16:28:27] Probing /cvmfs/alice-ocdb.cern.ch... OK
[2020-03-02 16:28:27] Probing /cvmfs/grid.cern.ch... OK
[2020-03-02 16:28:27] Probing /cvmfs/cms.cern.ch... OK
[2020-03-02 16:28:28] Probing /cvmfs/sft.cern.ch... OK
[2020-03-02 16:28:28] Probing /cvmfs/geant4.cern.ch... OK
[2020-03-02 16:28:29] Probing /cvmfs/na61.cern.ch... OK
[2020-03-02 16:28:29] Probing /cvmfs/boss.cern.ch... OK


It is highly recommended that you mount only those repositories that are required to run the selected LHC@home apps.
Repositories that are not used will just block resources on your side as well as server side.


Hence you should change your /etc/cvmfs/default.local as follows:
CVMFS_REPOSITORIES="atlas,atlas-condb,grid,cernvm-prod,sft,alice"

Then run "sudo cvmfs_config reload".
ID: 41809 · Report as offensive     Reply Quote
Profile Joseph Stateson

Send message
Joined: 10 Aug 08
Posts: 15
Credit: 741,892
RAC: 7
Message 41811 - Posted: 3 Mar 2020, 15:34:17 UTC - in response to Message 41809.  


It is highly recommended that you mount only those repositories that are required to run the selected LHC@home apps.
Repositories that are not used will just block resources on your side as well as server side.

Hence you should change your /etc/cvmfs/default.local as follows:
CVMFS_REPOSITORIES="atlas,atlas-condb,grid,cernvm-prod,sft,alice"


Done.
CVMFS_REPOSITORIES=atlas,atlas-condb,grid,cernvm-prod,sft,alice
CVMFS_QUOTA_LIMIT=4096
CVMFS_CACHE_BASE=/scratch/cvmfs
CVMFS_HTTP_PROXY=DIRECT
CVMFS_SEND_INFO_HEADER=yes

It appears that
CVMFS_REPOSITORIES=atlas.cern.ch,atlas-condb.cern.ch,grid.cern.ch,alice.cern.ch

also works on another of my Linux boxes, but not sure about the quotes you show in your post.

I restarted boinc and it appears the three Atlas tasks picked up where they left off as if they were "left in memory". I did not have "leave_apps_in_mermory" enabled as discussed here. Has checkpointing been implemented for natural code Atlas? There was less than 2 minutes difference in elapsed time after restarting boinc.

ID: 41811 · Report as offensive     Reply Quote
computezrmle
Volunteer moderator
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 15 Jun 08
Posts: 1439
Credit: 74,171,394
RAC: 109,370
Message 41812 - Posted: 3 Mar 2020, 16:01:39 UTC - in response to Message 41811.  

It appears that
CVMFS_REPOSITORIES=atlas.cern.ch,atlas-condb.cern.ch,grid.cern.ch,alice.cern.ch

also works on another of my Linux boxes, but not sure about the quotes you show in your post.

Regarding CVMFS_REPOSITORIES:
"repository" expands to "repository.cern.ch" if "CVMFS_DEFAULT_DOMAIN=cern.ch" is set.

Quotes are a must if the string contains characters that have a special meaning in your shell, e.g. ";" or "@".

To check the final settings including expanded variables "sudo cvmfs_config showconfig" or "sudo cvmfs_config showconfig -s" can be used. The "-s" might not be available in older versions.


Has checkpointing been implemented for natural code Atlas?

Sorry, should have posted a hint that ATLAS native can't use checkpoints and will start the calculation from the scratch.
ID: 41812 · Report as offensive     Reply Quote

Message boards : ATLAS application : Using 8 CPUs even if not showing 8 used?


©2020 CERN