log in

Atlas for Mac (Darwin)


Advanced search

Message boards : ATLAS application : Atlas for Mac (Darwin)

Author Message
Fuzzy Duck
Send message
Joined: 3 Dec 15
Posts: 2
Credit: 5,361,652
RAC: 3
Message 29717 - Posted: 30 Mar 2017, 5:59:33 UTC

I was running Atlas from the original website and have recently changed over to LHC.

I have noticed that all the WU's on my macbook pro are failing. Not sure why, given that they were running fine when taken directly from Atlas.

Here is an example of one the WU's.
https://lhcathome.cern.ch/lhcathome/result.php?resultid=129931920

maeax
Send message
Joined: 2 May 07
Posts: 182
Credit: 11,301,914
RAC: 11,411
Message 29720 - Posted: 30 Mar 2017, 8:24:05 UTC

Take this app_config.xml in the Boinc folder of the project:

lhcathome.cern.ch_lhcathome

<app_config>
<app>
<name>ATLAS</name>
<max_concurrent>1</max_concurrent>
</app>
<app_version>
<app_name>ATLAS</app_name>
<avg_ncpus>3</avg_ncpus>
<plan_class>vbox64_mt_mcore_atlas</plan_class>
<cmdline>--memory_size_mb 5000</cmdline>
</app_version>
</app_config>

avg_ncpus is the max CPUs you want to take part.

Memory_size_mb must be greater or equal 4.400.

David Cameron
Project administrator
Project developer
Project scientist
Send message
Joined: 13 May 14
Posts: 124
Credit: 2,875,749
RAC: 10,318
Message 29722 - Posted: 30 Mar 2017, 10:14:53 UTC

At first glance it looks like a segmentation fault in ATLAS code, i.e. a faulty WU, but all your WUs fail like this so it's not WU-specific.

I looked deeper into the logs and there is a problem reading database information. Maybe you have a firewall blocking the connection? Although the connections required in LHC are exactly the same as in the old ATLAS@Home.

computezrmle
Send message
Joined: 15 Jun 08
Posts: 347
Credit: 3,399,908
RAC: 3,711
Message 29726 - Posted: 30 Mar 2017, 15:47:49 UTC

When I changed my setting from 1 core WUs (running with 3400 MB) to 2 core WUs I noticed similar error messages in stderr.txt and the WUs didn´t validate.
Even 4480 MB were not enough.
With 5120 MB the most recent WU is now running.

I guess it´s a RAM issue instead of a firewall issue.

Fuzzy Duck
Send message
Joined: 3 Dec 15
Posts: 2
Credit: 5,361,652
RAC: 3
Message 29810 - Posted: 4 Apr 2017, 9:22:56 UTC - in response to Message 29726.

Guys,

Thank you for the info/assistance. I would advise that I updated my VM & BOINC on my machine and it now appears to be running OK. However, it has picked up one of the long WU's and is currently at day 4.

maeax
Send message
Joined: 2 May 07
Posts: 182
Credit: 11,301,914
RAC: 11,411
Message 31148 - Posted: 28 Jun 2017, 7:48:21 UTC

This Apple produce a lot of unresolved ATLAS-Tasks:

https://lhcathome.cern.ch/lhcathome/results.php?hostid=10467467

So, other Computer become those Tasks to finish them.

Message boards : ATLAS application : Atlas for Mac (Darwin)