Message boards : Theory Application : Cannot run native theory after debian upgrade
Message board moderation

To post messages, you must log in.

Previous · 1 · 2

AuthorMessage
Profile F6FGZ looking for DX !

Send message
Joined: 7 Jan 07
Posts: 39
Credit: 15,368,705
RAC: 519
Message 44259 - Posted: 3 Feb 2021, 20:02:57 UTC - in response to Message 44257.  
Last modified: 3 Feb 2021, 20:05:17 UTC

Verify that the /etc/systemd/system/multi-user.target.wants/boinc-client.service file has not been modified by the update process and looks like :
so you mean I have to *replace* the content of mine =

[Unit]
Description=Automounts filesystems on demand
After=network.target ypbind.service sssd.service network-online.target remote-fs.target
Wants=network-online.target

[Service]
Type=forking
PIDFile=/var/run/autofs.pid
EnvironmentFile=-/etc/default/autofs
ExecStart=/usr/sbin/automount $OPTIONS --pid-file /var/run/autofs.pid
ExecReload=/bin/kill -HUP $MAINPID
TimeoutSec=180

[Install]
WantedBy=multi-user.target

Be careful !!
This service seems to be related to Automount NOT BOINC !!
Yes, you will get the one needed as describe in this message which is at the top of this forum, or just copy/paste from the one provided above to replace the one you have.
As I think you are not sure about what you are doing, I recommend you to apply what is described above if you don't want mess your systemd configuration.
Here is an extract :
sudo wget http://lhcathome.cern.ch/lhcathome/download/create-boinc-cgroup -O /sbin/create-boinc-cgroup
sudo wget http://lhcathome.cern.ch/lhcathome/download/boinc-client.service -O /etc/systemd/system/boinc-client.service

GRUB_CMDLINE_LINUX_DEFAULT="console=ttyS0 vsyscall=emulate quiet"

I you want to stay close from the former one, you may omit the quiet parameter.
ID: 44259 · Report as offensive     Reply Quote
[AF>Le_Pommier] Jerome_C2005

Send message
Joined: 12 Jul 11
Posts: 76
Credit: 1,064,445
RAC: 0
Message 44260 - Posted: 3 Feb 2021, 22:45:28 UTC
Last modified: 3 Feb 2021, 23:01:27 UTC

OOOPS so it was really a good idea to ask first !! I don't know what file I did display, but the good one is :

~/KERNEL$ cat /etc/systemd/system/multi-user.target.wants/boinc-client.service
[Unit]
Description=Berkeley Open Infrastructure Network Computing Client
Documentation=man:boinc(1)
After=network-online.target

[Service]
ProtectHome=true
Type=simple
Nice=10
User=boinc
WorkingDirectory=/var/lib/boinc
ExecStart=/usr/bin/boinc
ExecStop=/usr/bin/boinccmd --quit
ExecReload=/usr/bin/boinccmd --read_cc_config
ExecStopPost=/bin/rm -f lockfile
IOSchedulingClass=idle

[Install]
WantedBy=multi-user.target

So this one is pretty similar to yours, but with a few less row, I guess it's ok ?

The rest you mention I had done it already.

I did the grub stuff and rebooted.

~$ find /sys/fs/cgroup/ -type d -name boinc -exec ls -ld {} \;|sort -k9,9
drwxrwxr-x 2 root boinc 0 févr. 3 23:33 /sys/fs/cgroup/blkio/boinc
drwxrwxr-x 2 root boinc 0 févr. 3 23:33 /sys/fs/cgroup/cpu,cpuacct/boinc
drwxrwxr-x 2 root boinc 0 févr. 3 23:33 /sys/fs/cgroup/cpuset/boinc
drwxrwxr-x 2 root boinc 0 févr. 3 23:33 /sys/fs/cgroup/devices/boinc
drwxrwxr-x 2 root boinc 0 févr. 3 23:33 /sys/fs/cgroup/freezer/boinc
drwxrwxr-x 2 root boinc 0 févr. 3 23:33 /sys/fs/cgroup/hugetlb/boinc
drwxrwxr-x 2 root boinc 0 févr. 3 23:33 /sys/fs/cgroup/memory/boinc
drwxrwxr-x 2 root boinc 0 févr. 3 23:33 /sys/fs/cgroup/net_cls,net_prio/boinc
drwxrwxr-x 2 root boinc 0 févr. 3 23:33 /sys/fs/cgroup/perf_event/boinc
drwxrwxr-x 2 root boinc 0 févr. 3 23:33 /sys/fs/cgroup/pids/boinc
~$ sudo grep emulate /var/log/syslog
Feb 3 23:33:01 vps400147 kernel: [ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.19.160 root=UUID=de672388-3374-460c-a771-f445373320db ro console=ttyS0 vsyscall=emulate
Feb 3 23:33:01 vps400147 kernel: [ 0.376853] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.19.160 root=UUID=de672388-3374-460c-a771-f445373320db ro console=ttyS0 vsyscall=emulate

I don't see the "quiet" in the latest since you told me to remove it, which I did.

So I assume I'm good to go ?

Wait & see, only 2 small tasks from another project to finish and we'll see :)

-----------
EDITH :
i wasn't patient, I killed the poor tasks and got some native tasks, one atlas native from LHC and one theory native from LHCdev and it seems to be running, no crash after several minutes and he log file is filling in the slog !!

IT SEEMS TO BE WORKING ! THANKS A LOT FOR ALL YOUR HELP !

mayge i'll find the courage to summarize all that you had me doing (only the parts that worked :) ) because we have a good linux/libriste community at l'Alliance Francophone forum and they'll certainly be very interested by all his !
ID: 44260 · Report as offensive     Reply Quote
Profile F6FGZ looking for DX !

Send message
Joined: 7 Jan 07
Posts: 39
Credit: 15,368,705
RAC: 519
Message 44261 - Posted: 4 Feb 2021, 10:10:08 UTC - in response to Message 44260.  

Contrats !
You step forward in the Linux learning curve :)
ID: 44261 · Report as offensive     Reply Quote
[AF>Le_Pommier] Jerome_C2005

Send message
Joined: 12 Jul 11
Posts: 76
Credit: 1,064,445
RAC: 0
Message 44281 - Posted: 7 Feb 2021, 18:19:10 UTC - in response to Message 44261.  
Last modified: 7 Feb 2021, 18:19:26 UTC

Pour ceux que ça intéresse j'ai essayé de franciser et synthétiser toutes les étapes sur le forum de l'Alliance Francophone :)

Merci encore F6FGZ qui cherche son DX !
ID: 44281 · Report as offensive     Reply Quote
[AF>Le_Pommier] Jerome_C2005

Send message
Joined: 12 Jul 11
Posts: 76
Credit: 1,064,445
RAC: 0
Message 44526 - Posted: 21 Mar 2021, 19:42:16 UTC

F6FGZ looking for DX ! HAAAAAALP !!

My poor little debian VM died with OVH disaster, so I installed a new one... with buster... and now I can't redo the same configuration again...

The make -j 2 bindeb-pkg is now failing with a new error :

scripts/kconfig/conf --syncconfig Kconfig
/bin/bash ./scripts/package/mkdebian
dpkg-buildpackage -r"fakeroot -u" -a$(cat debian/arch) -b -nc -uc
dpkg-buildpackage: info: source package linux-4.19.171
dpkg-buildpackage: info: source version 4.19.171-1
dpkg-buildpackage: info: source distribution buster
dpkg-buildpackage: info: source changed by jerome <jerome@vps-3dca72ac.vps.ovh.net>
dpkg-buildpackage: info: host architecture amd64
dpkg-source --before-build .
debian/rules build
make KERNELRELEASE=4.19.171 ARCH=x86 KBUILD_BUILD_VERSION=1 KBUILD_SRC=
DESCEND objtool
HOSTCC scripts/sign-file
scripts/sign-file.c:25:10: fatal error: openssl/opensslv.h: No such file or directory
#include <openssl/opensslv.h>
^~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[4]: *** [scripts/Makefile.host:90: scripts/sign-file] Error 1
make[3]: *** [Makefile:1082: scripts] Error 2
make[3]: *** Waiting for unfinished jobs....
make[2]: *** [debian/rules:4: build] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2
make[1]: *** [scripts/package/Makefile:80: bindeb-pkg] Error 2
make: *** [Makefile:1411: bindeb-pkg] Error 2


Also the version have changed, now I had to use

cp -p /boot/config-4.19.0-14-cloud-amd64 .config

I don't know if it has anything to do...

Thanks !
ID: 44526 · Report as offensive     Reply Quote
Profile F6FGZ looking for DX !

Send message
Joined: 7 Jan 07
Posts: 39
Credit: 15,368,705
RAC: 519
Message 44533 - Posted: 22 Mar 2021, 19:00:21 UTC - in response to Message 44526.  

Sorry for the fire at OVH datacenter, and it occured again !

About the kernel compilation, I followed instructions at the beginning of this thread.
I adjusted some release numbers, using current kernel 4.19.0-14 :
cp -p /boot/config-4.19.0-14-amd64 .config

Then unleashed the CPU's :
make -j 14 bindeb-pkg
.......
dpkg-deb: building package 'linux-headers-4.19.171' in '../linux-headers-4.19.171_4.19.171-1_amd64.deb'.
dpkg-deb: building package 'linux-libc-dev' in '../linux-libc-dev_4.19.171-1_amd64.deb'.
dpkg-deb: building package 'linux-image-4.19.171' in '../linux-image-4.19.171_4.19.171-1_amd64.deb'.
dpkg-deb: building package 'linux-image-4.19.171-dbg' in '../linux-image-4.19.171-dbg_4.19.171-1_amd64.deb'.
 dpkg-genbuildinfo --build=binary
 dpkg-genchanges --build=binary >../linux-4.19.171_4.19.171-1_amd64.changes
dpkg-genchanges: info: envoi des binaires seulement (le code source n'est pas inclus)
 dpkg-source --after-build .
dpkg-buildpackage: info: envoi d'un binaire seulement (aucune inclusion de code source)

The result :
ls -lh linux-*171*
-rw-r--r-- 1 f6fgz f6fgz 4,9K mars  22 19:52 linux-4.19.171_4.19.171-1_amd64.buildinfo
-rw-r--r-- 1 f6fgz f6fgz 2,3K mars  22 19:52 linux-4.19.171_4.19.171-1_amd64.changes
-rw-r--r-- 1 f6fgz f6fgz  11M mars  22 19:46 linux-headers-4.19.171_4.19.171-1_amd64.deb
-rw-r--r-- 1 f6fgz f6fgz  46M mars  22 19:47 linux-image-4.19.171_4.19.171-1_amd64.deb
-rw-r--r-- 1 f6fgz f6fgz 660M mars  22 19:51 linux-image-4.19.171-dbg_4.19.171-1_amd64.deb
-rw-r--r-- 1 f6fgz f6fgz 992K mars  22 19:46 linux-libc-dev_4.19.171-1_amd64.deb


Check if you have the following package installed :
dpkg -l libssl-dev
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom              Version                                     Architecture Description
+++-================-===========================================-============-================================================
ii  libssl-dev:amd64 1.1.1j-1+0~20210301.25+debian10~1.gbp2578a0 amd64        Secure Sockets Layer toolkit - development files
ID: 44533 · Report as offensive     Reply Quote
[AF>Le_Pommier] Jerome_C2005

Send message
Joined: 12 Jul 11
Posts: 76
Credit: 1,064,445
RAC: 0
Message 44534 - Posted: 22 Mar 2021, 23:29:38 UTC - in response to Message 44533.  
Last modified: 22 Mar 2021, 23:30:12 UTC

Et ben c'était ça !! pas de libssl-dev (j'avais vainement cherché quelle librairie il pouvait bien manquer), il manque toujours un paquet dans un coin avec ce merveilleux système :)

And now it's compiling, compiling, compiling... (on the 2 cores...), I'll see where it went tomorrow, thanks !!!
ID: 44534 · Report as offensive     Reply Quote
[AF>Le_Pommier] Jerome_C2005

Send message
Joined: 12 Jul 11
Posts: 76
Credit: 1,064,445
RAC: 0
Message 44540 - Posted: 23 Mar 2021, 21:13:38 UTC - in response to Message 44534.  

La victoire est en nous ! It's working for native theory again ! (lhcdev tasks) thanks !

(I had to adapt more versions #)

At start the Atlas native were failing, but in the error message I saw something about "singularity" so it rang me a bell and I found instructions on the forum for installation required for Atlas, I could do the installation steps for "go" and "singularity", hopefully it is working !

All this for boinc love... ;)
ID: 44540 · Report as offensive     Reply Quote
Previous · 1 · 2

Message boards : Theory Application : Cannot run native theory after debian upgrade


©2022 CERN