Message boards : Theory Application : Odd runtime and CPU time registered for a task
Message board moderation

To post messages, you must log in.

AuthorMessage
Harri Liljeroos
Avatar

Send message
Joined: 28 Sep 04
Posts: 547
Credit: 29,880,802
RAC: 11,620
Message 43596 - Posted: 13 Nov 2020, 9:38:58 UTC

https://lhcathome.cern.ch/lhcathome/result.php?resultid=288968731
The task above run for about 90 minutes with 1 CPU core as seen by the stderr log (from 06:03:44 to 07:36:01) but Boinc has recorded that runtime is 9,963.00 seconds and CPU time 79,704.00 seconds. BoincTasks has a record for runtime 1:32:19 and CPU time 116:09:37.

From message log:
234135	LHC@home	13.11.2020 6:03:43	[cpu_sched] Starting task Theory_2390-1125045-141_0 using Theory version 30006 (vbox64_theory) in slot 4	
...
234691	LHC@home	13.11.2020 7:36:03	Computation for task Theory_2390-1125045-141_0 finished	

Does anybody have an idea what could have happened?
ID: 43596 · Report as offensive     Reply Quote
Crystal Pellet
Volunteer moderator
Volunteer tester

Send message
Joined: 14 Jan 10
Posts: 1046
Credit: 6,601,227
RAC: 256
Message 43597 - Posted: 13 Nov 2020, 10:13:21 UTC - in response to Message 43596.  

Does anybody have an idea what could have happened?
Not really.
Probably you have in your project preferences "No Limit" for # of cpus and are using an app_config.xml.

Your machine has 8 threads and the number of CPU-seconds reported is about 8 times the real number.
ID: 43597 · Report as offensive     Reply Quote
Harri Liljeroos
Avatar

Send message
Joined: 28 Sep 04
Posts: 547
Credit: 29,880,802
RAC: 11,620
Message 43599 - Posted: 13 Nov 2020, 12:00:32 UTC - in response to Message 43597.  

Does anybody have an idea what could have happened?
Not really.
Probably you have in your project preferences "No Limit" for # of cpus and are using an app_config.xml.

Your machine has 8 threads and the number of CPU-seconds reported is about 8 times the real number.

The project preferences for this venue is set to 3 for # of CPUs. Below is the Theory section from app_config.xml:
	<app>
		<name>Theory</name>
		<max_concurrent>4</max_concurrent>
	</app>
	<app_version>
		<app_name>Theory</app_name>
		<plan_class>vbox64_mt_mcore</plan_class>
		<avg_ncpus>1.000000</avg_ncpus>
		<cmdline>--nthreads 1 --memory_size_mb 750</cmdline>
	</app_version> 

All other Theory tasks for this host have normal runtime and CPU time, this was the only one like this I happened to notice. The host does about 30-35 Theory tasks a day + 2 Atlas tasks a day. App_config sets Atlas also to use only 1 CPU core.
ID: 43599 · Report as offensive     Reply Quote
Greger

Send message
Joined: 9 Jan 15
Posts: 149
Credit: 431,596,822
RAC: 0
Message 43601 - Posted: 13 Nov 2020, 15:25:38 UTC - in response to Message 43599.  
Last modified: 13 Nov 2020, 15:26:18 UTC

Does anybody have an idea what could have happened?
Not really.
Probably you have in your project preferences "No Limit" for # of cpus and are using an app_config.xml.

Your machine has 8 threads and the number of CPU-seconds reported is about 8 times the real number.

The project preferences for this venue is set to 3 for # of CPUs. Below is the Theory section from app_config.xml:
	<app>
		<name>Theory</name>
		<max_concurrent>4</max_concurrent>
	</app>
	<app_version>
		<app_name>Theory</app_name>
		<plan_class>vbox64_mt_mcore</plan_class>
		<avg_ncpus>1.000000</avg_ncpus>
		<cmdline>--nthreads 1 --memory_size_mb 750</cmdline>
	</app_version> 

All other Theory tasks for this host have normal runtime and CPU time, this was the only one like this I happened to notice. The host does about 30-35 Theory tasks a day + 2 Atlas tasks a day. App_config sets Atlas also to use only 1 CPU core.


Strange cputime but notice that log report default 630MB in memory. Your app is set to 750MB, you might need to re-check config for this. If doesn't catch mem it may not use config for nthreads 1

stderr
Setting Memory Size for VM. (630MB)
ID: 43601 · Report as offensive     Reply Quote
Harri Liljeroos
Avatar

Send message
Joined: 28 Sep 04
Posts: 547
Credit: 29,880,802
RAC: 11,620
Message 43602 - Posted: 13 Nov 2020, 19:02:30 UTC - in response to Message 43601.  

Ok, I see that the plan_class I have used in app_config.xml (vbox64_mt_mcore) is not valid anymore. All my Theory tasks are running in plan_class vbox64_theory, also the one with odd CPU time. So my app_config is omitted for that part and default values are used. Still the mystery is why only this one task has calculation time values that are so different from the other Theory tasks on this host.
ID: 43602 · Report as offensive     Reply Quote

Message boards : Theory Application : Odd runtime and CPU time registered for a task


©2021 CERN