Message boards : CMS Application : fraction_done_exact - not working
Message board moderation

To post messages, you must log in.

AuthorMessage
Erich56

Send message
Joined: 18 Dec 15
Posts: 1265
Credit: 23,005,935
RAC: 1,958
Message 30197 - Posted: 4 May 2017, 9:36:18 UTC
Last modified: 4 May 2017, 9:40:56 UTC

some time ago, someone here in the LHC forum posted an app_config.xml which contained the line
<fraction_done_exact/>
which I know already from crunching GPUGRID. There is works perfectly, which means that the time shown as "remaining" in the BOINC Manager is exactly what is is.

However, here with CMS my experience is that in reality, the remaining time for a given task is much shorter than shown in the BOINC Manager.

What might be the reason for this malfunctioning of the app_config.xml?
ID: 30197 · Report as offensive     Reply Quote
Crystal Pellet
Volunteer moderator
Volunteer tester

Send message
Joined: 14 Jan 10
Posts: 942
Credit: 6,295,842
RAC: 1,120
Message 30198 - Posted: 4 May 2017, 10:02:10 UTC - in response to Message 30197.  

What might be the reason for this malfunctioning of the app_config.xml?

I don't think it's malfunctioning.
Could you check that the fraction done is related to the maximum run time of 18 hours and not the minimum of 12 hours?
ID: 30198 · Report as offensive     Reply Quote
Erich56

Send message
Joined: 18 Dec 15
Posts: 1265
Credit: 23,005,935
RAC: 1,958
Message 30199 - Posted: 4 May 2017, 10:25:27 UTC - in response to Message 30198.  

Could you check that the fraction done is related to the maximum run time of 18 hours and not the minimum of 12 hours?

I now checked - it's related to 18 hrs.
ID: 30199 · Report as offensive     Reply Quote
Erich56

Send message
Joined: 18 Dec 15
Posts: 1265
Credit: 23,005,935
RAC: 1,958
Message 30214 - Posted: 4 May 2017, 16:48:29 UTC

Does the above now mean that the <fraction_done_exact/> app_config.xml only shows the percentage value in relation to the maximum runtime of 18 hours, regardless of how long the task really runs?
In that case - unless I am missing something - the XML would not make a whole lot of sense, right?
ID: 30214 · Report as offensive     Reply Quote
Crystal Pellet
Volunteer moderator
Volunteer tester

Send message
Joined: 14 Jan 10
Posts: 942
Credit: 6,295,842
RAC: 1,120
Message 30216 - Posted: 4 May 2017, 17:24:38 UTC - in response to Message 30214.  

Does the above now mean that the <fraction_done_exact/> app_config.xml only shows the percentage value in relation to the maximum runtime of 18 hours, regardless of how long the task really runs?
In that case - unless I am missing something - the XML would not make a whole lot of sense, right?

To ? 1 - Yes
To ? 2 - Which xml?
ID: 30216 · Report as offensive     Reply Quote
Erich56

Send message
Joined: 18 Dec 15
Posts: 1265
Credit: 23,005,935
RAC: 1,958
Message 30217 - Posted: 4 May 2017, 17:29:27 UTC - in response to Message 30216.  

To ? 2 - Which xml?

the <fraction_done_exact/> app_config.xml which we are talking here about.
ID: 30217 · Report as offensive     Reply Quote
Crystal Pellet
Volunteer moderator
Volunteer tester

Send message
Joined: 14 Jan 10
Posts: 942
Credit: 6,295,842
RAC: 1,120
Message 30219 - Posted: 4 May 2017, 20:13:20 UTC - in response to Message 30216.  

In that case - unless I am missing something - the XML would not make a whole lot of sense, right?

The fraction_done makes no sense in the app_config here, cause the runtime of a task is between 12 and 18 hours, depending on the length of the last job running inside the VM.
ID: 30219 · Report as offensive     Reply Quote
Erich56

Send message
Joined: 18 Dec 15
Posts: 1265
Credit: 23,005,935
RAC: 1,958
Message 30223 - Posted: 5 May 2017, 4:40:48 UTC - in response to Message 30219.  

The fraction_done makes no sense in the app_config here ...

that's what I suspected. Thanks for the clarification, anyway.
ID: 30223 · Report as offensive     Reply Quote

Message boards : CMS Application : fraction_done_exact - not working


©2020 CERN