Message boards : Theory Application : 32Bit VM on Ubuntu - Could not get an x509 credential
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile LHCByloved
Avatar

Send message
Joined: 1 Mar 13
Posts: 7
Credit: 500,102
RAC: 0
Message 29469 - Posted: 21 Mar 2017, 2:51:40 UTC
Last modified: 21 Mar 2017, 3:21:26 UTC

Hi there

Well, being one of the last ones to move over here (was running my "old" VMs standalone/nonstop, so now had to get familiar with BOINC again and the changes/developements took place), as "welcome back present" got some kind of bug or a bit too early easter egg. ;-)

Just tried to run Theory Application on Ubuntu 16.04 32Bit (BOINC 7.6.31 + VBox 5.0.32) and got few tasks I tried, but all were aborting after a few minutes with computation error.

Having a look into Stderr revealed the following:

[INFO] Requesting an X509 credential from vLHC@home
[INFO] Requesting an X509 credential from vLHC@home-dev
(... repeating a few times...)
Guest Log: [ERROR] Could not get an x509 credential
Guest Log: [ERROR] The x509 proxy creation failed.
Guest Log: [INFO] Shutting Down.
(11897): VM Completion File Detected.
(11897): VM Completion Message: The x509 proxy creation failed.

Full Stderr file
https://lhcathome.cern.ch/lhcathome/result.php?resultid=127326519

On my other machine (MacOS 64Bit - running fine) while VM is booting I could see its asking for the credential instead from LHC@home (as also can be seen here on one of the 64Bit fine results), so possibly the 32Bit VM distributed to Ubuntu needs a little update to ask there either?

Greetings,
Bylo
ID: 29469 · Report as offensive     Reply Quote
Profile Laurence
Project administrator
Project developer

Send message
Joined: 20 Jun 14
Posts: 179
Credit: 204,121
RAC: 0
Message 29479 - Posted: 21 Mar 2017, 10:30:34 UTC - in response to Message 29469.  

You might be right. We will investigate.
ID: 29479 · Report as offensive     Reply Quote
Profile Laurence
Project administrator
Project developer

Send message
Joined: 20 Jun 14
Posts: 179
Credit: 204,121
RAC: 0
Message 29481 - Posted: 21 Mar 2017, 11:04:18 UTC - in response to Message 29479.  

The VM provided for the Linux version was not current. The application has been updated (v262.80). Please try again.
ID: 29481 · Report as offensive     Reply Quote
maeax

Send message
Joined: 2 May 07
Posts: 297
Credit: 12,611,159
RAC: 3,110
Message 29483 - Posted: 21 Mar 2017, 11:22:43 UTC
Last modified: 21 Mar 2017, 11:23:34 UTC

ID: 29483 · Report as offensive     Reply Quote
Profile Laurence
Project administrator
Project developer

Send message
Joined: 20 Jun 14
Posts: 179
Credit: 204,121
RAC: 0
Message 29489 - Posted: 21 Mar 2017, 13:46:12 UTC - in response to Message 29483.  

Sorry, no Ubuntu but XP(pro)
https://lhcathome.cern.ch/lhcathome/result.php?resultid=127228769


This is a different problem. It could be a problem with the installation of Virtual Box.
ID: 29489 · Report as offensive     Reply Quote
PHILIPPE

Send message
Joined: 24 Jul 16
Posts: 77
Credit: 161,617
RAC: 373
Message 29496 - Posted: 21 Mar 2017, 16:54:51 UTC - in response to Message 29489.  

In the log appears :

2017-03-20 10:23:45 (844): Hardware acceleration CPU extensions not detected. Disabling VirtualBox hardware acceleration support.
2017-03-20 10:23:45 (844): Disabling hardware acceleration support for virtualization.

Check in your bios if you have VT-X enabled and if HyperV is removed.
ID: 29496 · Report as offensive     Reply Quote
maeax

Send message
Joined: 2 May 07
Posts: 297
Credit: 12,611,159
RAC: 3,110
Message 29501 - Posted: 21 Mar 2017, 18:30:47 UTC

32-bit is running without acceleration (AMD-V or VT-X).
ID: 29501 · Report as offensive     Reply Quote
Profile MAGIC Quantum Mechanic
Avatar

Send message
Joined: 24 Oct 04
Posts: 563
Credit: 15,632,955
RAC: 9,803
Message 29515 - Posted: 21 Mar 2017, 22:20:08 UTC - in response to Message 29501.  

My XP Pro X86 has been running these Theory tasks for over 6 years now and it only has an occasional problem when it tries to start a new task and my slow DSL messes that up since it gets to 11 minutes without getting the Credentials

Only did that 3 times this month and the rest are Valids.
https://lhcathome.cern.ch/lhcathome/results.php?hostid=10447575

Of course with a 32bit X86 you can't use more than 4GB ram and that is what I use.

But yours only has 2GB ram Maeax so you should try to plug in another 2GB of the DDR2 ram to see if that is all you need.
Volunteer Mad Scientist For Life
ID: 29515 · Report as offensive     Reply Quote
maeax

Send message
Joined: 2 May 07
Posts: 297
Credit: 12,611,159
RAC: 3,110
Message 29517 - Posted: 22 Mar 2017, 2:24:48 UTC
Last modified: 22 Mar 2017, 2:29:34 UTC

Thank you Magic,

4 GByte RAM are not the problem.
There is a Kernel panic in RDP with bad EIP.... as info.

Saw you have Virtualbox 5.1.6. Will test this version next day.
ID: 29517 · Report as offensive     Reply Quote
tullio

Send message
Joined: 19 Feb 08
Posts: 472
Credit: 2,126,871
RAC: 303
Message 29518 - Posted: 22 Mar 2017, 2:58:36 UTC
Last modified: 22 Mar 2017, 3:00:22 UTC

All my 32-bit Theory tasks failed on the Linux box with kernel panic after 10 minutes. Now I have installed a 64-bit SuSE Leap 42.2 on the AMD E-450 and it works. But all LHC@home tasks on it fail save SixTrack which I am running to get some credits. BOINC 7.2.42, VBox 5.1.18.
Tullio
ID: 29518 · Report as offensive     Reply Quote
Profile MAGIC Quantum Mechanic
Avatar

Send message
Joined: 24 Oct 04
Posts: 563
Credit: 15,632,955
RAC: 9,803
Message 29535 - Posted: 22 Mar 2017, 20:35:15 UTC - in response to Message 29517.  

Thank you Magic,

4 GByte RAM are not the problem.
There is a Kernel panic in RDP with bad EIP.... as info.

Saw you have Virtualbox 5.1.6. Will test this version next day.


Yeah that was just a suggestion for when you do get the old beast running.

That VB version has worked fine for mine so I am sticking with it and am just doing this to keep my XP Pro X86 running since it has been running this OS since 2001 when it came out in November

It does run these Theory X3 and it is on the old Phenom 3-core.

On your first crash it started with *Hardware acceleration CPU extensions not detected. Disabling VirtualBox hardware acceleration support.
2017-03-20 10:23:45 (844): Disabling hardware acceleration support for virtualization.*


The ones from today look even worse as you probably saw.

https://lhcathome.cern.ch/lhcathome/result.php?resultid=127617280

Hope you get it running since I like seeing the XP Pro's still working.

The only problem mine has (this one and all the others) is that ISP problem where it doesn't get connected before the 11 minute mark to connect with the VC Condor port and get the Credentials and HTCondor Ping.

So I tend to try to watch when my next batch starts to see if my DSL is running fast enough......if not I make them wait so I don't get those extra Error's (I don't leave Boinc Manager able to get new tasks to avoid those over and over Errors that will stack up in the VB Manager)

Good luck......off to town for my doctor appointment.....
Volunteer Mad Scientist For Life
ID: 29535 · Report as offensive     Reply Quote
maeax

Send message
Joined: 2 May 07
Posts: 297
Credit: 12,611,159
RAC: 3,110
Message 29538 - Posted: 22 Mar 2017, 20:56:08 UTC

Boinc is 7.6.22 and Virtualbox is to old: 5.0.12.
This package was in combination for installation.
Next one will be Boinc 7.6.22 with Virtualbox 5.1.6. Hopeful with more success.
ID: 29538 · Report as offensive     Reply Quote
Profile LHCByloved
Avatar

Send message
Joined: 1 Mar 13
Posts: 7
Credit: 500,102
RAC: 0
Message 29543 - Posted: 23 Mar 2017, 2:22:35 UTC - in response to Message 29481.  

Hi Laurence

The VM provided for the Linux version was not current. The application has been updated (v262.80). Please try again.

It works fine now, Thank you a lot!

Greetings,
Bylo
ID: 29543 · Report as offensive     Reply Quote
Profile MAGIC Quantum Mechanic
Avatar

Send message
Joined: 24 Oct 04
Posts: 563
Credit: 15,632,955
RAC: 9,803
Message 29544 - Posted: 23 Mar 2017, 2:45:11 UTC - in response to Message 29538.  
Last modified: 23 Mar 2017, 2:45:45 UTC

Boinc is 7.6.22 and Virtualbox is to old: 5.0.12.
This package was in combination for installation.
Next one will be Boinc 7.6.22 with Virtualbox 5.1.6. Hopeful with more success.


Yeah one major problem I always had on all of my computers when it came to running the VB was trying to d/l Boinc AND VB from that home page link.......NEVER worked for me so years ago I just d/l Boinc and then go to https://www.virtualbox.org/wiki/Downloads ......to get the version of VB and Extension Pack

And the reboot before starting any tasks.
Volunteer Mad Scientist For Life
ID: 29544 · Report as offensive     Reply Quote

Message boards : Theory Application : 32Bit VM on Ubuntu - Could not get an x509 credential


©2018 CERN