Message boards : Number crunching : New Version of Boinc
Message board moderation

To post messages, you must log in.

AuthorMessage
madmac
Avatar

Send message
Joined: 25 Aug 05
Posts: 42
Credit: 3,518
RAC: 0
Message 9756 - Posted: 31 Aug 2005, 13:06:24 UTC

I understand that there is a new version of Boinc coming out, will it work with LHC and other boinc sites.

ID: 9756 · Report as offensive     Reply Quote
Gaspode the UnDressed

Send message
Joined: 1 Sep 04
Posts: 506
Credit: 118,619
RAC: 0
Message 9757 - Posted: 31 Aug 2005, 13:52:13 UTC
Last modified: 31 Aug 2005, 13:52:43 UTC

There's always a new version of BOINC coming out. The real question is just 'Will it work?'

More seriously, though, there are a number of changes in the pipeline. You can get the details from the BOINC web site here.

The thing to look for is a change of major version number (i.e. from 4.xx to 5.xx). if the major version changes then V5 clients will not work with V4 servers and vice versa. In this case there will be a period of transition where participants need to choose which projects to run, and accept the limitations that implies.

If the major version does not change then the clients and servers should interoperate freely. However, there have been numerous examples of minor version changes rendering certain projects inoperative.

From what I read the changes are involved with the internal mechanics, rather than major changes. It remains to be seen which projects transition smoothly and which have difficulties.


Gaspode the UnDressed
http://www.littlevale.co.uk
ID: 9757 · Report as offensive     Reply Quote
Profile Ed and Harriet Griffith
Avatar

Send message
Joined: 18 Sep 04
Posts: 37
Credit: 4,051
RAC: 0
Message 9758 - Posted: 31 Aug 2005, 14:03:15 UTC

BOINC 5.1.1 can be downloaded at http://boinc.berkeley.edu/download.php?dev=1

ID: 9758 · Report as offensive     Reply Quote
Profile FZB

Send message
Joined: 17 Sep 04
Posts: 23
Credit: 6,357,977
RAC: 395
Message 9760 - Posted: 31 Aug 2005, 14:33:48 UTC

right now 5.1.1 does not work with the public projects...
ID: 9760 · Report as offensive     Reply Quote
BarkerJr

Send message
Joined: 30 Sep 04
Posts: 21
Credit: 50,260
RAC: 0
Message 9909 - Posted: 4 Sep 2005, 3:25:18 UTC - in response to Message 9760.  

Wrong. It works with SETI and Einstein, which I assume both still work with 4.x clients. So, it seems that 5.x server is compatible with 4.x clients.
ID: 9909 · Report as offensive     Reply Quote
Heffed

Send message
Joined: 2 Sep 04
Posts: 71
Credit: 8,657
RAC: 0
Message 9914 - Posted: 4 Sep 2005, 5:31:14 UTC - in response to Message 9909.  

<blockquote>Wrong. It works with SETI and Einstein, which I assume both still work with 4.x clients. So, it seems that 5.x server is compatible with 4.x clients.</blockquote>
The servers will always be backwards compatible, but the project can set a low end cutoff for old clients.
ID: 9914 · Report as offensive     Reply Quote
Mahray

Send message
Joined: 18 Sep 04
Posts: 12
Credit: 31,580
RAC: 0
Message 9916 - Posted: 4 Sep 2005, 7:49:35 UTC - in response to Message 9914.  

I believe some of the projects have loosened their version checking, however 5.1 is still in development.
ID: 9916 · Report as offensive     Reply Quote
Profile MAGIC Quantum Mechanic
Avatar

Send message
Joined: 24 Oct 04
Posts: 961
Credit: 40,681,002
RAC: 7,555
Message 9917 - Posted: 4 Sep 2005, 9:44:07 UTC
Last modified: 4 Sep 2005, 9:49:23 UTC

[b]
I'm still running the first version on this machine (my fastest one) and on another one and a newer version on another one.


LHC and Einstein with my worlds slowest dialup connection!


But the only trouble I ever have is when the site runs out of work




Volunteer Mad Scientist For Life
ID: 9917 · Report as offensive     Reply Quote
John McLeod VII
Avatar

Send message
Joined: 2 Sep 04
Posts: 165
Credit: 146,925
RAC: 0
Message 9931 - Posted: 5 Sep 2005, 18:05:12 UTC

Server code more than a month or so old will not connect to 5.1.x as the server code does a check against the major version and fails to connect if the server version and the client version have different major versions. I posted a list of projects that failed to the dev mail list on Friday. At that time, it was most of the projects.


BOINC WIKI
ID: 9931 · Report as offensive     Reply Quote
Ian Thompson

Send message
Joined: 18 Sep 04
Posts: 35
Credit: 60,866
RAC: 0
Message 9958 - Posted: 7 Sep 2005, 7:19:53 UTC

Hi All

I have tried the 5.1.x Client and have found the following issues.

Upgrading my 4.72 Client everything appears to work.
What I did notice was that No new work appears not to work.
This was an issues as I was clearing out the cache to reinstall my OS.
so I downgraded back to 4.72. This did cause minor issues but a reboot resolved them and a repair install.

After I reloaded my OS I installed the client a fresh.

It did not want to connect to LHC it did to einstein & seti
It asked me for an email address and password. which I don't have. also if you type garbage it comes up with same not successfully connected message.

So I downgraded again.

I think they should sort out these issues for the next release.

More detailed error messages would be useful.


<img border="0" src="http://boinc.mundayweb.com/one/stats.php?userID=2104" />
ID: 9958 · Report as offensive     Reply Quote
Gaspode the UnDressed

Send message
Joined: 1 Sep 04
Posts: 506
Credit: 118,619
RAC: 0
Message 9959 - Posted: 7 Sep 2005, 8:44:53 UTC - in response to Message 9958.  

>>It did not want to connect to LHC it did to einstein & seti

It won't connect to LHC - LHC is not upgraded to cope with it.

It will connect to Einstein and SETI - they have been upgraded.

See this very thread for more details.


V5.1.x remains a development version at present. Bugs and issue should be reported in the SETI forums, which is where BOINC was developed.

Gaspode the UnDressed
http://www.littlevale.co.uk
ID: 9959 · Report as offensive     Reply Quote
Profile Paul D. Buck

Send message
Joined: 2 Sep 04
Posts: 545
Credit: 148,912
RAC: 0
Message 9964 - Posted: 7 Sep 2005, 10:55:50 UTC - in response to Message 9959.  

<blockquote>V5.1.x remains a development version at present. Bugs and issue should be reported in the SETI forums, which is where BOINC was developed.
</blockquote>
Actually, it should be reported in the BOINC forums.
ID: 9964 · Report as offensive     Reply Quote
Gaspode the UnDressed

Send message
Joined: 1 Sep 04
Posts: 506
Credit: 118,619
RAC: 0
Message 9970 - Posted: 7 Sep 2005, 12:21:43 UTC - in response to Message 9964.  

<blockquote><blockquote>V5.1.x remains a development version at present. Bugs and issue should be reported in the SETI forums, which is where BOINC was developed.
</blockquote>
Actually, it should be reported in the BOINC forums.</blockquote>

Oops - slip of the finger...

:-(


Gaspode the UnDressed
http://www.littlevale.co.uk
ID: 9970 · Report as offensive     Reply Quote
John McLeod VII
Avatar

Send message
Joined: 2 Sep 04
Posts: 165
Credit: 146,925
RAC: 0
Message 10075 - Posted: 11 Sep 2005, 21:42:17 UTC - in response to Message 9970.  

<blockquote><blockquote><blockquote>V5.1.x remains a development version at present. Bugs and issue should be reported in the SETI forums, which is where BOINC was developed.
</blockquote>
Actually, it should be reported in the BOINC forums.</blockquote>

Oops - slip of the finger...

:-(

</blockquote>

The BOINC Forums are only a month or two old. Not everyone has gotten used to them yet.


BOINC WIKI
ID: 10075 · Report as offensive     Reply Quote
itenginerd
Avatar

Send message
Joined: 29 Aug 05
Posts: 42
Credit: 27,102
RAC: 0
Message 10079 - Posted: 12 Sep 2005, 2:40:07 UTC - in response to Message 9756.  

Grrr. Just went to 5.1.1 on my main LHC box and wish I read this thread first (or before starting my own thread on the topic). Works great, other than it doesn't work with LHC. Good thing I've got 2 other projects to crunch...

I'm going to stick with 5.1.1 until LHC catches up. I know it's still an alpha release, but it's crunching fine for me, and I can weather some bumps in the road...

ID: 10079 · Report as offensive     Reply Quote
Profile The Gas Giant

Send message
Joined: 2 Sep 04
Posts: 309
Credit: 715,258
RAC: 0
Message 10080 - Posted: 12 Sep 2005, 3:27:27 UTC - in response to Message 10079.  

<blockquote>Grrr. Just went to 5.1.1 on my main LHC box and wish I read this thread first (or before starting my own thread on the topic). Works great, other than it doesn't work with LHC. Good thing I've got 2 other projects to crunch...

I'm going to stick with 5.1.1 until LHC catches up. I know it's still an alpha release, but it's crunching fine for me, and I can weather some bumps in the road...

</blockquote>

I thought 5.1.3 has been released....
Paul
(S@H1 8888)
BOINC/SAH BETA
ID: 10080 · Report as offensive     Reply Quote
itenginerd
Avatar

Send message
Joined: 29 Aug 05
Posts: 42
Credit: 27,102
RAC: 0
Message 10093 - Posted: 12 Sep 2005, 12:55:17 UTC - in response to Message 10080.  

<blockquote>I thought 5.1.3 has been released....</blockquote>

It has. I try to stay one step off the bleeding edge. Would have the same problem, though. It's a mismatch of the major-version, checked by the scheduler when you try to get work. There's plenty of Wiki on it. If only I'd known that I'd have this question before I had this question... 8)

(j)
James
ID: 10093 · Report as offensive     Reply Quote

Message boards : Number crunching : New Version of Boinc


©2020 CERN