1) Message boards : Number crunching : VirtualBox ~^~~-- 6.1.38 --~~^~ (released September 02 2022) (Message 47338)
Posted 2 Oct 2022 by captainjack
In Windows 11, Settings, Privacy and Security, Windows Security, Device Security, there is a setting for Core Isolation. The description says that it is a virtualization-based security that protects the core parts of your device. If that is on, try turning it off and see if you get any tasks.

On both of my Windows 11 computers, it that option it turned on, I get no tasks from LHC. When I turn it off, I get tasks.
2) Message boards : Number crunching : VirtualBox ~^~~-- 6.1.38 --~~^~ (released September 02 2022) (Message 47332)
Posted 30 Sep 2022 by captainjack

Which version of Windows are you running?

Were you ever able to receive vbox tasks on your computer running that version of the operating system?
3) Message boards : ATLAS application : Bad WUs? (Message 47218)
Posted 2 Sep 2022 by captainjack
After reading through several other posts about this kind of problem, I thought I might have network problems. I shut down all computers, the switch and finally the router. Then restarted the router, then the switch, then computers. Atlas tasks work again. What had me confused was that all other internet connections worked just fine so I didn't think it was a network issue. But a reboot got ATLAS tasks going again. Hope this helps someone else having similar issues.
4) Message boards : ATLAS application : Bad WUs? (Message 47213)
Posted 31 Aug 2022 by captainjack
For the past two days, I haven't been able to get any ATLAS tasks to run on Windows boxes. I've tried two different Windows 11 computers and one Windows 10 computer. All had previously successfully completed multiple ATLAS tasks. On prior successful tasks, there is a message in the stderr.txt that says:

2022-08-27 17:09:53 (16204): Guest Log: 00:00:00.000603 main 5.2.32 r132073 started. Verbose level = 0
2022-08-27 17:09:59 (16204): Guest Log: CVMFS is ok

Now I get a message that says:

2022-08-30 21:52:02 (16276): Guest Log: 00:00:00.002213 main 5.2.32 r132073 started. Verbose level = 0
2022-08-30 21:52:12 (16276): Guest Log: 00:00:10.017953 timesync vgsvcTimeSyncWorker: Radical guest time change: 18 010 622 070 000ns (GuestNow=1 661 914 332 064 570 000 ns GuestLast=1 661 896 321 442 500 000 ns fSetTimeLastLoop=true )

And then it just sits there and does nothing.

Any suggestions?
5) Message boards : ATLAS application : app_config.xml parameters question (Message 46794)
Posted 18 May 2022 by captainjack
Can't guarantee that this is perfect, but it works for me and doesn't throw any errors in the Event Log.

           <cmdline>--nthreads 5</cmdline>
6) Message boards : ATLAS application : Running (0.517 CPUs) (Message 43524)
Posted 23 Oct 2020 by captainjack
Just got another one of these. Task says it is "Running(0.849 CPUs)"

More tasks get started than the system can support and the ATLAS task gets suspended. I had to put in an app_config to restrict some of the other work to get the ATLAS task to restart.

Does anybody besides me think this is a problem?
7) Message boards : ATLAS application : Running (0.517 CPUs) (Message 43390)
Posted 22 Sep 2020 by captainjack
Machine I used for this test has 12 threads and 15.9 GB of memory.

I let LHC download 6 single core ATLAS tasks and started them one at a time. After each task had time to download additional data and go through all the initiation steps, I checked memory usage and started the next task.

With one task running, Windows plus the task was using 6.6 GB of memory.
With two tasks running, Windows plus 2 tasks were using 10.8 GM of memory.
With three tasks running, Windows plus 3 tasks were using 14.8 GB of memory.
With four tasks running, memory usage got up to 15.8 GB, it started banging away on the swap file, the system locked up and rebooted itself.

No tasks initiated with use of a partial CPU.

Once the system came back up, I limited LHC to 3 concurrent tasks and will let them run to completion with no other tasks running.
8) Message boards : ATLAS application : Running (0.517 CPUs) (Message 43389)
Posted 21 Sep 2020 by captainjack
djoser suggested:

You could try to set those on hold (or even remove them from BOINC) and see how ATLAS behaves with no other projects interfering.

Good question. I will let the queue drain down to empty on one of my machines then let it download as many single CPU ATLAS tasks as it wants and see what happens. I already know it will be constrained by memory, but it will be interesting to see what happens.
9) Message boards : ATLAS application : Running (0.517 CPUs) (Message 43387)
Posted 21 Sep 2020 by captainjack
If anybody wants to look into this further, the Task number is 283389454 and the work unit number is 145065835.

I just aborted the task after it ran for 4 days 15 hours 56 min 18 sec without a successful completion.

I would be glad to help test a possible solution, just let me know when and where.
10) Message boards : ATLAS application : Running (0.517 CPUs) (Message 43385)
Posted 21 Sep 2020 by captainjack

Thanks for the reply.

Yes, I am running the virtualbox version of ATLAS and yes, I have been through Yerti's checklist.

I have a screen capture of BOINC Manager with one of the ATLAS tasks in question that shows it using 0.517 CPUs that I would be glad to send to a project admin if someone will tell me where to send it.
11) Message boards : ATLAS application : Running (0.517 CPUs) (Message 43383)
Posted 21 Sep 2020 by captainjack
Additional information: It appears to me that since BOINC Manager on the desktop thinks that the ATLAS task only needs a fraction of a CPU, BOINC Manager will start more tasks than it has CPU's available. When all started tasks get going and ask for the resources they need, a task will get suspended then restarted frequently. When an ATLAS task has been running longer than any of the other tasks, it gets suspended and restarted more than any other task. When this happens, ATLAS tasks run much longer than they should if left uninterrupted.
12) Message boards : ATLAS application : Running (0.517 CPUs) (Message 43373)
Posted 19 Sep 2020 by captainjack
Got an Atlas task that shows that it is running using 0.517 CPUs. Is this normal?

If you need more info, please let me know.
13) Questions and Answers : Preferences : Use web preferences PROBLEM (Message 43318)
Posted 7 Sep 2020 by captainjack
Enzo Ricci,

The BOINC manager on your desktop will use the web preferences of the project (WCG or LHC) that were saved last. Since you added WCG, those are the preferences that were saved last. My suggestion would be to open up your preferences for LHC and save them (giving them the current time stamp) then issue an update in your BOINC Manager on your desktop.

Let us know if that works.
14) Message boards : Number crunching : Local control of which subprojects run`2 (Message 37276)
Posted 8 Nov 2018 by captainjack

The app_config.xml file does not control which tasks get downloaded. All the app_config.xml file does is control the manner in which the downloaded tasks run (number concurrent, memory size, etc.). The only way to control which tasks get downloaded is by using the project preferences.

A complete description of options for the app_config.xml file can be found at the bottom of https://boinc.berkeley.edu/wiki/client_configuration

Hope that helps.
15) Questions and Answers : Preferences : Stoping delivery of new tasks don't work in LHC@home and Seti@home (Message 36701)
Posted 13 Sep 2018 by captainjack

In the BOINC Manager app, when looking at the tab for "Tasks", there is a Command on the left panel for "Show Active Tasks" or "Show All Tasks". If you have it set to show only active tasks, then you may have tasks that are downloaded but do not show up until they become active. Please check to see if it is set for "Show All Tasks".

Hope that helps.
16) Message boards : Theory Application : Theory and app_config ? (Message 36670)
Posted 8 Sep 2018 by captainjack
You are welcome, glad you got it working.

One other clue that you might find useful in the future, it there is any doubt about which names to use in the app_config.xml, you can find many of the names for the current version in the client_state_prev.xml file located in the BOINC data folder.

Good luck with your crunching.
17) Message boards : Theory Application : Theory and app_config ? (Message 36667)
Posted 8 Sep 2018 by captainjack
Hi Yeti,

Try the following app_config.xml

    <cmdline>--nthreads 1</cmdline>

I just put this together and it appears to be working running theory on one thread.

The two main differences are the plan_class and the addition of a cmdline for --nthreads.

Also, in your app_config, there are several parameters that I do not find in the BOINC documentation for client configuration http://boinc.berkeley.edu/wiki/client_configuration.

I do not know how the undocumented parameters in your app_config affect the client configuration, my suggestion is to use the minimum parameters until you find something that works then add parameters.

Also, just in case you didn't know, when you add parameters to an app_config, you can activate the new parameters by clicking on "Options", "Read Config Files" in the BOINC Manager. If you need to remove parameters, it is best to shut down BOINC and start it back up with the new parameters in place.

Hope that helps, let us know how it turns out.
18) Message boards : ATLAS application : VirtualBox 5.2 (Message 36363)
Posted 9 Aug 2018 by captainjack
Machine is running Windows 10 - 1803, VB 5.2.16 and BOINC 7.12.1.

Tried running a 3-core ATLAS, 2-core Theory, and a 1-core LHCb tasks at the same time.

The Stderr.txt for the ATLAS task had the following error message:
2018-08-09 12:57:11 (1988): Error creating VirtualBox instance! rc = 0x80004002

While the tasks were processing, the machine stopped running. When I restarted it, the Event Log had this message:

8/9/2018 3:41:13 PM | LHC@home | [error] no project URL in task state file

Atlas task finished and validated, Theory and LHCb tasks are still running.

Let me know if you need more information.
19) Questions and Answers : Getting started : Issues changing email address (Message 35244)
Posted 12 May 2018 by captainjack
I can't change my email address here or at the test site either. Maybe when they fix it here, it will work there too.
20) Message boards : ATLAS application : Download failures (Message 32824)
Posted 13 Oct 2017 by captainjack
The task fetch seems to ignore the parameter for "Max # CPUs". For computer 10476963 the Max # CPUs was changed to 2, but the server keeps sending 4 core tasks. The client_state.xml says


Seems odd that the max_ncpus is 2, but the avg_ncpus is 4.

Computer is using the default preferences.

Please let me know if I can provide more information.

Next 20

©2022 CERN