Message boards : ATLAS application : Guide for building everything from sources to run native ATLAS on Debian 9 (Stretch) Version 2
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3

AuthorMessage
Jim1348

Send message
Joined: 15 Nov 14
Posts: 581
Credit: 19,251,878
RAC: 30,425
Message 42826 - Posted: 10 Jun 2020, 18:31:35 UTC - in response to Message 36880.  

Again, feel free to report mistakes, improvements, ask questions, make any suggestions, etc. It would be much appreciated!

OK, I will. While this has worked several times for me, on my latest installation of Singularity (on Ubuntu 18.04.4), when running "make" I get:
go: updates to go.sum needed, disabled by -mod=readonly

My small amount of searching indicates that some people think this is a feature, not a bug. That is not much help however.
Thanks if you can fix it.
ID: 42826 · Report as offensive     Reply Quote
Jim1348

Send message
Joined: 15 Nov 14
Posts: 581
Credit: 19,251,878
RAC: 30,425
Message 42851 - Posted: 12 Jun 2020, 18:20:27 UTC - in response to Message 42826.  

Problem solved, maybe.
I have been able to install Singularity 3.5.3 using these instructions:
https://sylabs.io/guides/3.0/user-guide/installation.html

Now we just need native ATLAS to work. One step at a time.
ID: 42851 · Report as offensive     Reply Quote
Jim1348

Send message
Joined: 15 Nov 14
Posts: 581
Credit: 19,251,878
RAC: 30,425
Message 44486 - Posted: 14 Mar 2021, 22:33:42 UTC - in response to Message 42851.  

Problem solved, maybe.
That procedure no longer works for me on my latest Ubuntu 20.04.2 build, but this one does.
https://lhcathome.cern.ch/lhcathome/forum_thread.php?id=5616&postid=44485#44485

It is actually simpler, and gives you a recent version of GO, along with the latest version (3.7.2) of Singularity.
Lots of luck.
ID: 44486 · Report as offensive     Reply Quote
M0CZY
Avatar

Send message
Joined: 27 Jun 06
Posts: 14
Credit: 69,025
RAC: 286
Message 45016 - Posted: 27 May 2021, 12:32:03 UTC - in response to Message 44486.  

I want to update my old version of Singularity for the latest version for Atlas workunits.
Should I install Singularity 3.7.4, or SingularityCE 3.8.0 ? Which version is correct for Boinc?
ID: 45016 · Report as offensive     Reply Quote
Profile F6FGZ looking for DX !

Send message
Joined: 7 Jan 07
Posts: 39
Credit: 15,236,582
RAC: 978
Message 45019 - Posted: 27 May 2021, 20:45:19 UTC - in response to Message 45016.  
Last modified: 27 May 2021, 20:47:26 UTC

Singularity 3.7.3 is current.
I updated the procedure mentioned above.
ID: 45019 · Report as offensive     Reply Quote
vigilian

Send message
Joined: 23 Jul 05
Posts: 53
Credit: 2,700,643
RAC: 208
Message 45027 - Posted: 28 May 2021, 6:55:16 UTC - in response to Message 45019.  

Singularity 3.7.3 is current.
I updated the procedure mentioned above.



which go version did yo use? because @computezrmle mentioned in another thread that he tried 1.15 and it didn't work but 1.14 was working. I just tried to build the dependencies for go 1.14.5 which is an archived version and I can get all the deps. So did you use the last go version and succeeded to build singularity? or did you use an older one?
ID: 45027 · Report as offensive     Reply Quote
vigilian

Send message
Joined: 23 Jul 05
Posts: 53
Credit: 2,700,643
RAC: 208
Message 45028 - Posted: 28 May 2021, 7:02:01 UTC - in response to Message 45027.  

Singularity 3.7.3 is current.
I updated the procedure mentioned above.



which go version did yo use? because @computezrmle mentioned in another thread that he tried 1.15 and it didn't work but 1.14 was working. I just tried to build the dependencies for go 1.14.5 which is an archived version and I can get all the deps. So did you use the last go version and succeeded to build singularity? or did you use an older one?



github.com/golang/dep/gps
# github.com/golang/dep/gps
/root/go/pkg/mod/github.com/golang/dep@v0.5.4/gps/constraint.go:103:21: cannot use sv (type *semver.Version) as type semver.Version in field value
/root/go/pkg/mod/github.com/golang/dep@v0.5.4/gps/constraint.go:122:16: invalid type assertion: c.(semver.Version) (non-interface type *semver.Constraints on left)
/root/go/pkg/mod/github.com/golang/dep@v0.5.4/gps/constraint.go:149:4: undefined: semver.Constraint

ID: 45028 · Report as offensive     Reply Quote
vigilian

Send message
Joined: 23 Jul 05
Posts: 53
Credit: 2,700,643
RAC: 208
Message 45032 - Posted: 28 May 2021, 11:11:19 UTC - in response to Message 45028.  

no okey I didn't notice that you were referencing another step by step than the original post from this thread. With yours I 've succeeded to install 3.7.2 :)
thanks
ID: 45032 · Report as offensive     Reply Quote
Profile tazzduke

Send message
Joined: 24 Jun 10
Posts: 31
Credit: 2,681,128
RAC: 2,496
Message 45345 - Posted: 16 Sep 2021, 8:50:22 UTC - in response to Message 45032.  

Greetings All

Had to rebuild one of my workstations, some of the computer details are as follows

Computer - ID: 10695708
Linux Mint 20.2
Kernel Version - 5.4.0-84
Boinc Version - 7.16.6
GO Version - go1.17.1
Singularity Version - 3.8.0-rc.1+287-g5a02820ef

Followed the instructions at the start of this thread, so I could do Atlas Native Tasks.

I installed all the packages, then started from Build and install cvmfs, however it did stop during make, as I needed to install python-setuptools.

Then I ran the make command again and then it continued successfully.

Completed this workunit successfully - https://lhcathome.cern.ch/lhcathome/result.php?resultid=325379002

Cheers
ID: 45345 · Report as offensive     Reply Quote
Previous · 1 · 2 · 3

Message boards : ATLAS application : Guide for building everything from sources to run native ATLAS on Debian 9 (Stretch) Version 2


©2022 CERN